Disabled-state for menuitems with a command set is never updated

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mano, Assigned: jaas)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The disabled state of menuitems without a command set is never updated, see code in nsMenuItemX::AttributeChanged.
(Assignee)

Comment 1

12 years ago
*** Bug 346955 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

12 years ago
Created attachment 241907 [details] [diff] [review]
fix v1.0
Attachment #241907 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #241907 - Flags: review? → review?(mano)
(Assignee)

Comment 3

12 years ago
See duped bug 346955 for an example of the problems this causes.
Comment on attachment 241907 [details] [diff] [review]
fix v1.0

r=mano
Attachment #241907 - Flags: review?(mano) → review+
(Assignee)

Updated

12 years ago
Attachment #241907 - Flags: superreview?(mikepinkerton)
Comment on attachment 241907 [details] [diff] [review]
fix v1.0

i don't think it should be case-sensitive, but it appears we are in lots of other places too...

sr=pink
Attachment #241907 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 6

12 years ago
fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.