All users were logged out of Bugzilla on October 13th, 2018

Refactor Content-Disposition Handling

RESOLVED DUPLICATE of bug 589292

Status

()

RESOLVED DUPLICATE of bug 589292
12 years ago
8 years ago

People

(Reporter: sayrer, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
HttpChannel should know its own content-disposition, so we can factor the code that's getting all over the tree. See bug 355332.
seems familiar to me, are you sure it's not a duplicate?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> seems familiar to me, are you sure it's not a duplicate?

nope.
I don't think we have a separate bug on this.  It came up in bug 224209, but that's all I can find.
Blocks: 224209, 344111, 345311
No longer blocks: 345311

Comment 4

12 years ago
(In reply to comment #1)
> seems familiar to me
Bug 299372 ?
Absolutely not.
renamed bug, as we want this for the JAR and Multipart channels as well, and to unify their interface.  The current plan is to make them all inherit from nsPropertyBag, and store the disposition info there.

This is already done for nsJARChannel (bug474536)--I'm going to implement for the other two.

So far I've put just the raw header in ("attachment; filename=foo.jar"), but I may add logic to split the attachment and filename parts, and store them separately as "content-disposition" and "content-disposition-filename."  Right now we're doing a lot of duplicate parsing of the raw header in various places, which is silly and probably error-prone.   Cleaning up the various usage sites is also part of this bug.
Assignee: nobody → jduell.mcbugs
Status: NEW → ASSIGNED
Summary: HttpChannel should know its own content-disposition → Http,JAR,Multipart Channels should have common way to get content-disposition
Jason, you're not working on this anymore are you?
Kyle,

No.  The code is working, and refactoring it isn't even close to the top of my todo list.
Assignee: jduell.mcbugs → nobody
Assignee: nobody → me
Component: Networking: HTTP → Networking
OS: Mac OS X → All
QA Contact: networking.http → networking
Hardware: x86 → All
Summary: Http,JAR,Multipart Channels should have common way to get content-disposition → Refactor Content-Disposition Handling
Kyle,

We're in the middle of trying to rip out the entire nsPropertyBag interface from channels (it doesn't work well with electrolysis), and we haven't figured out how that will look yet, so I'd recommend working on something else for now.
Assignee: me → nobody
Status: ASSIGNED → NEW
(In reply to comment #9)
> Kyle,
> 
> We're in the middle of trying to rip out the entire nsPropertyBag interface
> from channels (it doesn't work well with electrolysis), and we haven't figured
> out how that will look yet, so I'd recommend working on something else for now.

Heh, ok.  Guess I'll abandon this for now.
We'll fix this in 589292
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589292
You need to log in before you can comment on or make changes to this bug.