Cannot open new tab with doubleclick if many tabs are open

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

When you open more then 4 tabs there is no room to double click for a new tab. There are other options like Control-T, File New Tab, and Middle clicking. The double click feature is useless once you have greater then 4 tabs open.

Reproducible: Always

Steps to Reproduce:
1.Open Four websites
2.See there is no room to double click to open 5th tab
3.

Actual Results:  
Open Firefox
Open 4+ websites
See there is no room to double click the tab bar and open a new tab

Expected Results:  
Room to double click to generate the 5th or 6th tab.
I'm afraid this is WONTFIX because bug 312896 made an end to the sensitivity of the tab bar to double clicks above and below tabs.
Maybe you'll find a solution in Bug 345950 comment 1. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

11 years ago
This is not a doubleclick above and below the tabs. It is double click between the last tab and the "list all tabs" button when 7 or more tabs are open. A space should be left in between the last tab and the "list all tabs" button to be able to double click and get a new tab.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 3

11 years ago
this is an enhancement request, but leaving unused space in tab bar sounds like a bad thing. 
There is nothing in the tabbar that can be used to open a new tab with the mouse when the tabbar is full. There is elsewhere, but not there.
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Duplicate of this bug: 363753

Updated

11 years ago
Summary: No room to double click for new tab when 4+ tabs are open → Cannot open new tab with doubleclick if many tabs are open
(Reporter)

Comment 5

11 years ago
Why would leaving 5px of space be a bad thing? A user gets use to a "new tab" method then must look for a new method once they reach a certain number of tabs. 

Comment 6

11 years ago
I'm using Tab Clicking Options extension - http://twanno.mozdev.org/ , I've set it  to open new tab when double clicking on a tab and this way I don't have to find empty space on tabbar and I'm protected against lack of such space.
So maybe just allow this action and it would nicely fix this bug :) (could be in a form of hidden pref at least) ?

Comment 7

10 years ago
It (double clicking an empty spot on the tab bar to open a new tab) is a weird feature if it stops being available if/when more than 4 tabs are open.
We have a new tab button in the tab strip that serves this purpose now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.