When you print a job with Firefox, neither the Website address, or the name of program printing it appear in the print job.

REOPENED
Unassigned

Status

()

Core
Printing: Output
--
enhancement
REOPENED
11 years ago
6 years ago

People

(Reporter: Orlando, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Hello Firefox, 

 I work for a computer lab for the school of pharmacy in LIU. We love your program, the search engine dropdown list is great. However, we can not seem to screen printjobs using our program Printmanager from Software Shelf International, Inc.


When you print a job with Firefox, neither the Website address, or the name of program printing it appear in the print job.  

 

If you open the Print Queue that has a print job from Firefox, it just has a simple name such as below it just has Google.  From Internet explorer, it has the full URL which gives us something consistent to block, such as http://.

 

Here is a webstie to the actual program - we have worked extensively with Sean Lower (Software Shelf International, Inc.). Consequently, we have tried for a year and have not found a solution. 

Can anyone on your team shed some light on how we can resolve this issue? 

IF not we might have to remove the browser from the lab. 

I can be contacted at this information below.

Orlando Ross 
718.246.6359
oross@liu.edu

thanks 

OR 


Reproducible: Always

Steps to Reproduce:
1.Print job 
2.information get held in print Que
3.

Actual Results:  
Nothing is screened - everything is printed 

Expected Results:  
unwanted and wasted paper should be screened 

Can someone call me or Software Shelf directly? 


Software Shelf International, Inc.
Sean Lower
601 Cleveland Street, Suite# 710
Clearwater, FL 33755
Phone# 727-445-1920
Fax# 727-445-9223
www.softwareshelf.com


Or
 

 

Orlando Ross
Lab Coordinator
Pharmaceutical Computer Center
Arnold & Marie Schwartz
College of Pharmacy and Health Sciences
718.246.6359
Orlando.Ross@liu.edu
(Reporter)

Comment 1

11 years ago
Created attachment 241950 [details]
Email from Printmanger showing the difference between printing in Firefox and IE 6

When you print a job with Firefox, neither the Website address, or the name of program printing it appear in the title of the print job.  

If you open the Print Queue that has a print job from Firefox, it just has a simple name from the document title for the website such as below it just has Google.

In Internet explorer, if you print google, the document title includes the whole URL, such as http://www.google.com in the Printer document title.

This allows our software to know it is a web page because it has http:// in the job.

Comment 2

11 years ago
Comment on attachment 241950 [details]
Email from Printmanger showing the difference between printing in Firefox and IE 6

This is actually a word document. It shows that IE is using the page's URL as the "document name" in the print queue, while Firefox uses the page's title.
Attachment #241950 - Attachment mime type: text/html → application/msword
Assignee: nobody → printing
Component: Page Info → Printing
Product: Firefox → Core
QA Contact: page.info
Version: unspecified → 1.8 Branch

Updated

10 years ago
Duplicate of this bug: 386341
Assignee: printing → nobody
QA Contact: printing

Comment 4

7 years ago
can you still reproduce?
Keywords: testcase-wanted
Whiteboard: [closeme 2011-02-01]

Comment 5

7 years ago
Printing the www.google.com homepage creates a print job title of "Google" with Firefox 3.6.3 and also with Firefox 4b8 (tested on win7)
Please file a new bug if you can reproduce the problem in Firefox 4.  Thanks.
WFM, per last comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 7

7 years ago
The last comment (mine?) was to say that it did NOT add any recognizable keyword in the print job, using the html title, instead of the url (or adding "Firefox - xxxx" in front of the title. So this is STILL a problem. Sorry if i wasn't clear.

I have the latest Firefox 4.0 (osx) and I can still reproduce this problem. Printing www.google.com homepage produce a print job with title "Google", like it was in 3.6 and before.

What we would like:
* FF using the url as the print job's title ("http://www.google.com/")
* or, if the url can be a privacy problem, adding a static keyword in front or at the end of the title. ("Mozilla Firefox - Google")

What it is currently doing:
* using only the content of the <head/> tag, which can be anything.

Why it's important:
* To be able to recognize automatically a web page printed with FF, and depending of the print policy in place in the organization, allow/deny the job, change it's priority, force it in black&white, etc... 
* This is important in public places or schools/universities where the printing costs can go out of hand very fast.
I thought that was the desired result.  Thanks for clarifying.
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: testcase-wanted
Resolution: WORKSFORME → ---
Whiteboard: [closeme 2011-02-01]
Version: 1.8 Branch → unspecified
As far as I can tell, Opera 11 and Google Chrome 12 behaves as Firefox 4
(using just the page title for the print job name, "Google" in this case).

(In reply to comment #7)
> Why it's important:
> * To be able to recognize automatically a web page printed with FF, and
> depending of the print policy in place in the organization,
> allow/deny the job, change it's priority, force it in black&white, etc... 
> * This is important in public places or schools/universities where the
> printing costs can go out of hand very fast.

So what you're saying is that you want a recognizable keyword for
print jobs from Firefox so you can deny them to print?
I don't see how that's in the best interest of our users to be honest.

Implementing "Firefox - <page title>" is trivial but I think this needs a
policy decision whether we want to do this.
Whiteboard: WONTFIX?

Comment 10

7 years ago
Maybe I should explain the context for this request. 

The "users" here are the managers and administrators of public networks for schools, universities or private companies, and NOT home users. These users (our customers) are confronted with very high costs and increasing printing budget and want a way to setup a printing policy (due to budget restriction, and so on). So we are talking about FF installed on some intranet, or a publicly accessible internet workstation.

In the worse case, the print job would be denied, but usually it is just a notification or some kind of message asking the user if he REALLY needs to print this "Fw: Fw: Fw: Re: Chain Mail" mail thread in high-quality color.

This is also plugged into "Think of the Trees" communication compaigns where the popup will display environmental and cost data regarding the potential print job. The point here being that the consequence is decided by the managers and system administrators, and not the employee/student themselves, and the level of scrutiny is adaptive.

So yes, the "Firefox - ..." solution would be ideal. I don't see how it would be a problem for home users either, because they would never install this kind of software solution, and would not really care about it ?

One compromise solution would be to add a configuration option (somewhere in about:config ?) to specify the title keyword, if there was a way for a sysadmin to deploy this setting on all Firefox 4 installed on the network and make it readonly ?

These customers are mostly ex-IE 5/6 intranets starting to open up a little, and they usually block installation of alternative browsers for these reasons (and others). That's not something i like to see, hence why i'm trying to find a way to make this work on FF too.
(In reply to comment #10)
> One compromise solution would be to add a configuration option (somewhere in
> about:config ?) to specify the title keyword, if there was a way for a sysadmin
> to deploy this setting on all Firefox 4 installed on the network and make it
> readonly ?

FWIW: for deploying this, it'd probably make sense to use an addon (if this behavior is exposed in an addon-customizable way -- in the simplest case, via an about:config pref), and then the sysadmin in question would deploy a BYOB-customized version of Firefox ( http://byob.mozilla.com/ ) to the machines in question, rather than the official Firefox release.
You need to log in before you can comment on or make changes to this bug.