[regression][IME] Incorrect KO text input behavior

VERIFIED FIXED in M16

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
8 years ago

People

(Reporter: blee, Assigned: Joe Francis)

Tracking

({inputmethod})

Trunk
x86
Windows NT
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Load a page with text input field.
2. Switch on to [ko]IME (MS Global IME or native IME in KO Windows).
3. Type in ko words(e.g. "akak sksk" on EN KB) to text input fields (including
   Sidebar Search text field) and;
i) Hit space bar and repeat the step with Enter (return) key.
ii) Hit Backspace repeatedly to the last Jamo element.

==> Hitting space bar or return key after text input repeats the last char.
==> Hitting Backspace repetitiously fails to delete all Jamo elements of last 
characte before deleting preceding input by each character leaving the first 
Jamo of the last char input. Correct behavior is to delete the last char input 
completely by Jamo element and delete any previous ones by the whole character.

bld tested: Win 04-12-06-M15 
            w/ MS GlobalIME in Win NT J and native KO IME in Win 2k KO.
(Reporter)

Updated

18 years ago
QA Contact: teruko → blee

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Updated

18 years ago
Blocks: 35012
(Assignee)

Comment 1

18 years ago
assigning to me.
Assignee: ftang → jfrancis
Status: ASSIGNED → NEW
(Assignee)

Comment 2

18 years ago
I'm pretty sure part ii) of this bug is fixed.  Part i) may also be fixed.  Since 
I don't have KO IME, I'm marking fixed so that blee can verify.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

18 years ago
Fixed in Win 04-17-12-M16 bld.
Status: RESOLVED → VERIFIED
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.