Adds a duplicate extension suffix for downloaded files on VFAT

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
6 years ago

People

(Reporter: arunmarjun, Unassigned)

Tracking

({qawanted})

1.8 Branch
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

I am using Firefox 2.0 rc2 and am having a problem I have with SuSE's Firefox 1.5.0.3 too. Whats happening is that when I download a file like lets say abc.tar.gz it asks me where to save it and i select a location like /home/asd/. As soon as the download starts and the download manager windows pops up the file name appears as abc.tar.gz.gz and after the file's downloaded it is abc.tar.gz.gz .When this started happening in 1.5.0.3 i downloaded the 1.5.0.4 which made the problem go away, but with RC2 its propped up again.

Reproducible: Always

Steps to Reproduce:
1. download any file from the internet with an file extension
2. save it to you hard disk
3. you see the extension is suffixed again
(Reporter)

Comment 1

12 years ago
Created attachment 242074 [details]
download window

Comment 2

12 years ago
Problem still exists in firefox 2.0 (it didn't exist in former versions like 1.5.0.7).
Created attachment 244385 [details]
download manager screenshot

I can confirm this bug, however it only happens to me when saving files to my usb  pen drive.
Comment on attachment 244385 [details]
download manager screenshot

Using firefox 2.0
(Reporter)

Comment 5

12 years ago
I usually download into a common partition shared between windows and Linux which is FAT32. Its only in this folder if i download the extension is duplicated. downloading into any other folder works fine.
(Reporter)

Comment 6

12 years ago
Another wierd observation. I have SUSE Linux 10.0. I wanted to upgrade the Firefox which came with the distribution which is at 1.5.0.7. I downloaded the rpm and tried upgrading. The upgrade was not completely successful but it did run. I ran it once and tried to download a file to the shared FAT32 partition and it downloaded it without adding a duplicate extension. Then I ran the Firefox version I downloaded from mozilla.com website and everything seems to be fine!!!
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 8

11 years ago
I still see it happen in FF2.0. Actually, I reformatted the partition to NTFS from FAT for various reasons and it is still happening. Sometimes a tar.gz is saved as a tar.gz.tar and sometimes a mp3 file is saved as a mp3 with no additional extensions being added. 

Updated

11 years ago
Whiteboard: CLOSEME 07/14
Version: 1.5.0.x Branch → 2.0 Branch

Comment 9

11 years ago
 This issue is present in the current Debian development release (Lenny 20090928 - Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 ) and eLive Gem 1.0 (different version than Debian's).
 I can confirm it happens when downloading to FAT32 partitions and does not in ext3 ones.
 Test: Every torrent file in http://zerowing.idsoftware.com:6969/ gets the double .torrent when downloaded to FAT32 file systems.

Comment 10

11 years ago
Edit: Lenny 20070928
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Comment 12

11 years ago
 I can cofirm this bug is fixed in Debian Lenny (Testing): Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080129 Iceweasel/2.0.0.12 (Debian-2.0.0.12-1).
 It works properly since the last Iceweasel update for all file extensions I have tested (mp3, zip, rar, gz and the torrents from my test URL).
(Reporter)

Comment 13

11 years ago
I havent had this happen to me for a while now. I have Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Ubuntu/7.10 (gutsy) Firefox/2.0.0.13

I will mark this fixed unless others are still having problems, wherein they can reopen this bug.

Resolution: INCOMPLETE → FIXED

Updated

11 years ago
Resolution: FIXED → WORKSFORME

Comment 14

11 years ago
(In reply to comment #11)
> Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still
> see this issue, please reopen.
> 

Sorry for insisting - but the problem still occurs (even in version 2.0.0.13).
It only occurs for downloads to a windows VFAT filesystem but not for downloads to a native linux filesystem (i.e. ext3).

Could you please reopen the issue? I don't see any button to do that :-(
Thanks.

Updated

11 years ago
Status: RESOLVED → UNCONFIRMED
Keywords: qawanted
Resolution: WORKSFORME → ---

Comment 15

11 years ago
(In reply to comment #12)
>  I can cofirm this bug is fixed in Debian Lenny (Testing): Mozilla/5.0 (X11; U;
> Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080129 Iceweasel/2.0.0.12
> (Debian-2.0.0.12-1).
>  It works properly since the last Iceweasel update for all file extensions I
> have tested (mp3, zip, rar, gz and the torrents from my test URL).
> 

(In reply to comment #14)
> Sorry for insisting - but the problem still occurs (even in version 2.0.0.13).
> It only occurs for downloads to a windows VFAT filesystem but not for downloads
> to a native linux filesystem (i.e. ext3).

Adding information:
My tests where run for all the filesystems I use: ext3, vfat (FAT32) and NTFS (using ntfs-3g) and were succesful for all of them.

Comment 16

11 years ago
Created attachment 313791 [details]
screenshots showing that the problem still exists

The tarball contains 5 screenshots showing several stages of a download to a VFAT-filesystem - where the problem still occurs.

1.jpg shows the destination folder before starting the download
2.jpg shows the dialog for choosing the operation (with the correct extension)
3.jpg shows the dialog for choosing the destination (still with the correct extension)
4.jpg show the downloadmanager after downloading the file (with the wrong extension)
5.jpg shows the destination folder after the download containing the file with the duplicate extention
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 17

9 years ago
With firefox-3.5.3 the problem doesn't exist anymore. IMHO this issue can be marked as fixed.

Updated

6 years ago
Summary: Adds a duplicate extension suffix for downloaded files → Adds a duplicate extension suffix for downloaded files on VFAT
wfm per comment #17
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.