Status

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: neoclust, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061003 Firefox/2.0

i obtain this error message :

gmake[6]: Leaving directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/protocol/gopher/src'
gmake[5]: Leaving directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/protocol/gopher'
gmake[4]: Leaving directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/protocol'
gmake[4]: Entering directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/system'
gmake[4]: Leaving directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/system'
gmake[4]: Entering directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/build'
nsNetModule.cpp
gmake[4]: *** No rule to make target `../protocol/jar/src/libnkjar_s.a', needed by `libnecko.so'.  Stop.
gmake[4]: *** Waiting for unfinished jobs....
c++ -o nsNetModule.o -c -fvisibility=hidden -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000 -DIMPL_NS_NET -I./../base/src -I./../dns/src -I./../socket/base -I./../streamconv/src -I./../streamconv/converters -I./../mime/src -I./../cache/src -I./../protocol/about/src  -I./../protocol/http/src  -I./../protocol/ftp/src  -I./../protocol/file/src  -I./../protocol/jar/src  -I./../protocol/res/src  -I../../dist/include/xpcom -I../../dist/include/string -I../../dist/include/nkcache -I../../dist/include/pref -I../../dist/include/mimetype -I../../dist/include/locale -I../../dist/include/intl -I../../dist/include/uconv -I../../dist/include/unicharutil -I../../dist/include/caps -I../../dist/include   -I../../dist/include/necko -I../../dist/include/nspr    -I../../dist/sdk/include -I/usr/include   -fPIC  -I/usr/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fomit-frame-pointer -march=i586 -mtune=pentiumpro -fasynchronous-unwind-tables -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fomit-frame-pointer -march=i586 -mtune=pentiumpro -fasynchronous-unwind-tables  -I/usr/include -DMOZILLA_CLIENT -include ../../mozilla-config.h -Wp,-MD,.deps/nsNetModule.pp nsNetModule.cpp
gmake[4]: Leaving directory `/home/neoclust/rpm/BUILD/mozilla-sunbird-0.3/mozilla/netwerk/build'


Reproducible: Always

Steps to Reproduce:
I try to compile with this configure options :

%configure --disable-debug --enable-xprint --enable-strip-libs --disable-mathml --with-system-zlib --enable-toolkit=gtk2 --enable-default-toolkit=gtk2 --disable-tests --disable-freetype2 --enable-optimize="$RPM_OPT_FLAGS" --with-default-mozilla-five-home=%{mozillalibdir} --enable-single-profile --disable-profilesharing --disable-ldap --disable-mailnews --enable-extensions=pref,xmlextras --enable-crypto --disable-composer --enable-plaintext-editor-only --enable-necko-protocols=about,http,ftp,file,jar,res --disable-accessibility --disable-activex --disable-activex-scripting --disable-installer --disable-jsd --disable-mathml --disable-necko-disk-cache --disable-oji --disable-view-source --disable-logging --disable-plugins --disable-cookies --enable-application=calendar --enable-xft --disable-pango
Are you trying to build Sunbird using a mozconfig file from Firefox?

The 'official' mozconfig file used to build Sunbird 0.3 looks like:

mk_add_options MOZ_CO_PROJECT=calendar
mk_add_options MOZ_MAKE_FLAGS="-j6"
mk_add_options JS_READLINE=1
ac_add_options --enable-application=calendar
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-static
ac_add_options --disable-shared
ac_add_options --disable-installer
ac_add_options --disable-tests
ac_add_options --enable-default-toolkit=gtk2
(Reporter)

Comment 3

12 years ago
i don't use anything from firefox, 
so you suggest me to configure only with :


./configure --enable-application=calendar --disable-debug --enable-optimize --enable-static --disable-shared --disable-installer --disable-tests --enable-default-toolkit=gtk2 --enable-application=calendar 

?

if yes i will try
Are you building with source pulled from CVS or with the download package?

You use --enable-necko-protocols=about,http,ftp,file,jar,res
but Sunbird uses only about,http,ftp,file,res

This might be the reason why the source for jar protocol isn't in the download package and therefore the build fails at this point.
(Reporter)

Comment 5

12 years ago
you are right, w/o the jar option it builds correctly.
sorry for the noise
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.