grey style for signature extends beyond signature for forwarded mail

RESOLVED DUPLICATE of bug 54570

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 54570
12 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

grey style for signature extends beyond signature for forwarded mail

let me attach a screen shot and a test message

I'm using tbird mac os x version 2 beta 1 (20061011)
(Assignee)

Comment 3

12 years ago
I'm curious how you managed to get your signature above the forwarded message. it's supposed to always be at the bottom for forwards. I was unable to tweak my settings to get that to happen :)
that was a test message, which mimicked a email I couldn't attach to bugzilla.  

I've asked the author (basil) to tell me which mailer he used.

but I can share the original email with you privately.

Comment 5

12 years ago
I used the Zimbra webmail client that Justin has foisted on us recently :-)

As an FYI, I have "Add signatures to all outgoing messages checked". There is another option that says "Place signature at the bottom of the entire message" which for me is unchecked.

The exact text of my Signature is:
-- 
Basil Hashem
basil@mozilla.com

(Note the space following the --)

My guess is that TB is processing the "-- " sequence special somehow.
Created attachment 242119 [details]
bug exhibited in basil's last bug email
(Assignee)

Comment 7

12 years ago
Hmm, I'm sure there's an RFC somewhere that says don't insert signatures at the top of forwarded messages. yes we do treat -- special, good call Basil. -- (followed by a line return) is the universal delimiter for signatures in email and most mail clients like thunderbird treat everything that follows --\n as a signature...

Comment 8

12 years ago
There is a longstanding bug already on thunderbird or seamonkey to better determine what's a signature, so that large parts of the email that are not meant to be seen as a signature, despite following a signature delimiter, are not printed in grey text.

If it happens a lot, you can add an entry to the usercontent.css file to change the signature colour. (For example, make it black.)
https://bugzilla.mozilla.org/show_bug.cgi?id=54570#c40

Comment 9

10 years ago
(In reply to comment #8)
> There is a longstanding bug already on thunderbird or seamonkey to better
> determine what's a signature, so that large parts of the email that are not
> meant to be seen as a signature, despite following a signature delimiter, are
> not printed in grey text.
> 
> If it happens a lot, you can add an entry to the usercontent.css file to change
> the signature colour. (For example, make it black.)
> https://bugzilla.mozilla.org/show_bug.cgi?id=54570#c40

Isn’t this a dup of 54570?

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 54570
You need to log in before you can comment on or make changes to this bug.