Turn all tests on argo off

RESOLVED FIXED

Status

Webtools Graveyard
Tinderbox
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Adam Guthrie, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Today around 10:00 PDT Ts went up on argo and Tp saw a slight decrease. No other tinderboxes showed this, and bonsai tells me that no patches went in that could have affected these numbers, so it must be due to the tinderbox itself.

It would be nice to know what causes stuff like this to happen. It screws up perf. numbers and someone going back a month from now and seeing this is not going to know, "Oh, that's when such and such changed; it's really not "real" perf. regression."

Comment 1

11 years ago
All perf numbers that should be used for anything useful should be coming from the Testing Tinderboxen, not from the build tinderboxen.

The machine for this is: Linux bl-bldlnx01 Dep argo test perf

I'll post to mozilla.dev.builds, but argo's perf numbers should be turned off. (And actually, the story for Linux builds on trunk should be figured out; it looks like both argo and prometheus are doing builds. Anyone know the story behind that?)
Summary: Investigate why argo's Ts numbers went up and Tp went down → Turn all tests on argo off
Can we get argo tests turned off asap?  It's reporting what is, as best I can tell, bogus data.  (See dev.performance)
(Reporter)

Comment 3

11 years ago
We need to figure out what's causing the random spikes in Ts times on bl-bldlnx01 first, IMO.

I talked to rhelmer on IRC about this a few weeks ago. He says he thought it might be due to some type of cron jobs running. He said he was going to turn them off and see if it made a difference.

Comment 4

11 years ago
Tests on argo are turned off.

ispiked: if there's a spike on bl-bldlnx01, then is there a bug on it with details (when the spike occurs, etc.)?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

11 years ago
I filed bug 357068 on the spike I mentioned in comment 3.

Updated

7 years ago
Component: Tinderbox Configuration → Tinderbox
Product: mozilla.org → Webtools
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.