mail filter on "body contains" fails when message is over a certain size

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
11 years ago

People

(Reporter: a9909, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060909 FreeBSD/i386 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060909 FreeBSD/i386 Firefox/1.5.0.7

One of my nightly scripts sends out an email with an "Update" alert at the very bottom.

Unfortunately, it's rather dumb, so it doesn't modify the subject or anything - it will detect if something needs my attention, and output this phrase as the second-to-last line in the cron email.

I set up a mail filter to detect when this phrase occurs (since it doesn't happen every time), but it seems to have trouble when the data preceding the message is over a certain length (approx. 2kb)

The filter is:
Match any; Body contains "** ADDRESSBOOK UPDATED **"; move to New Addressbook folder

The emails don't have attachments, they're just textual output (output from a "diff", in this case), but if they are over 2kb the match doesn't seem to occur. Because the Thunderbird size listing is ... shall we say ... inaccurate, I can't nail down an exact byte threshhold that this occurs at. It seems that one or two "2kb" messages have matched properly, but several 2kb ones have failed, and one 5kb one failed - there haven't been any in between that range that I can test with.



Reproducible: Sometimes

Steps to Reproduce:
1. Create a message filter on "body contains" to move a message based on a string
2. Receive an email with 2 or 3 kb of text *before* the string occurs

Actual Results:  
The message doesn't seem to move.

Expected Results:  
The message should move to the desired folder.

This is with Thunderbird 1.5.0.7, 20060909.

Comment 1

11 years ago
Kevin,
imap or pop?
are you on version 2 yet?

Comment 2

11 years ago
no response from reporter

=> incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
Version: unspecified → 1.5
(Reporter)

Comment 3

11 years ago
It's under POP3, and 1.5.0.12 at the moment (Fedora Core 6).

However, I modified the script that is sending the message, so it's no longer a concern.
You need to log in before you can comment on or make changes to this bug.