Clicking on the *.jar does not trigger the "theme install" dialogue, but rather the "file save" dialogue

RESOLVED FIXED in 3.0

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Peter J. Nicol, Assigned: wenzel)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

http://releases.mozilla.org/pub/mozilla.org/themes/noia_2.0_extreme_/noia_2.0_extreme_-3.12-fx.jar  triggers "file save"

http://releases.mozilla.org/pub/mozilla.org/themes/noia_2.0_extreme_/noia_2.0_extreme_-3.29-fx.jar triggers "install theme".

What's a boy to do?

Reproducible: Always

Steps to Reproduce:
As for above
Actual Results:  
As for above

Expected Results:  
Well, it should have installed the theme.

No obvious work around.
(Reporter)

Comment 1

11 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7)
> Gecko/20060909 Firefox/1.5.0.7
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7)
> Gecko/20060909 Firefox/1.5.0.7
> 
> http://releases.mozilla.org/pub/mozilla.org/themes/noia_2.0_extreme_/noia_2.0_extreme_-3.12-fx.jar
>  triggers "file save"
> 
> http://releases.mozilla.org/pub/mozilla.org/themes/noia_2.0_extreme_/noia_2.0_extreme_-3.29-fx.jar
> triggers "install theme".

Actually, it may be some form of CSS issue, as clicking on both links above in Bugzilla generates the same "file save" dialogue, as opposed to the behaviour in addons.mozilla.org where the latest release triggers the "theme install" but the old release does not.  

> 
> Reproducible: Always
> 
> Steps to Reproduce:
> As for above
> Actual Results:  
> As for above
> 
> Expected Results:  
> Well, it should have installed the theme.
> 
> No obvious work around.
> 

--> addons.mozilla.org :: Public Pages
Component: *.mozilla.org → Public Pages
Product: Websites → addons.mozilla.org
QA Contact: other-mozilla-org → web-ui
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> --> addons.mozilla.org :: Public Pages
> 

Sorry, I don't understand that ^^^^

Also, there is a workaround that seems to confirm to me that it is some funky css or javascript thingy.

I saved the "good" page locally, and re-wrote the url on the 'install' button to the older jar I needed and it works.
The 'Install Now' button on an extension/theme's main page uses a javascript InstallTrigger to bring up the install window for extensions/themes. The history page does not make use of this trigger, but rather links directly to the file.

I imagine this was done on purpose, probably because these older versions are for reference and shouldn't be installed in most cases.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.0
I left this bug open because I couldn't decide if I thought history should use installTrigger or not, but I guess I don't see why it shouldn't. Confirming this to be fixed in Remora.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 3.0
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Assignee: nobody → fwenzel
Status: ASSIGNED → NEW
(Assignee)

Comment 6

11 years ago
This is fixed in remora: I used the regular install button for the history page as well.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.