Closed Bug 356722 Opened 13 years ago Closed 13 years ago

Calendar view displays without colors and no toolbar icons are shown

Categories

(Calendar :: Lightning Only, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: mattwillis)

References

()

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Regression:
No toolbar icons shown for Lightning buttons
No icons shown in Add-ons Manager
Calendar view is displayed without styling/colors

Works in Lightning/0.4a1 2006-10-13-09-mozilla1.8
Fails in Lightning/0.4a1 2006-10-14-07-mozilla1.8
Blocks: 350406
Attached patch fixes jar.mn (obsolete) — Splinter Review
Adds skin files to classic.jar (rather than calendar.jar).
This is where http://lxr.mozilla.org/mozilla/source/calendar/lightning/chrome.manifest
tells the app they are.
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #242326 - Flags: second-review?(jminta)
Attachment #242326 - Flags: first-review?(ssitter)
Attached patch fix lightning (obsolete) — Splinter Review
ssitter found that the previous fix moved the problem to Sunbird.
The problem is that Lightning expects skin files in classic.jar, while Sunbird expects them in calendar.jar

This patch changes lightning's chrome manifest to match Sunbird's behaviour: look for calendar skin files in calendar.jar, and puts lightning skin files in lightning.jar.
Attachment #242326 - Attachment is obsolete: true
Attachment #242329 - Flags: second-review?(jminta)
Attachment #242329 - Flags: first-review?(ssitter)
Attachment #242326 - Flags: second-review?(jminta)
Attachment #242326 - Flags: first-review?(ssitter)
Comment on attachment 242329 [details] [diff] [review]
fix lightning

Yes, this fixes the calendar view and the toolbar icons. 
But now the minimonth is without styling and the icon in preference dialog is missing too.
Attachment #242329 - Flags: first-review?(ssitter) → first-review-
Attached patch correct patchSplinter Review
I had attached the wrong patch.

Try this. My apologies
Attachment #242329 - Attachment is obsolete: true
Attachment #242334 - Flags: second-review?(jminta)
Attachment #242334 - Flags: first-review?(ssitter)
Attachment #242329 - Flags: second-review?(jminta)
Comment on attachment 242334 [details] [diff] [review]
correct patch

Yep, that works better. r=ssitter
Attachment #242334 - Flags: first-review?(ssitter) → first-review+
Comment on attachment 242334 [details] [diff] [review]
correct patch

over to dmose per jminta
Attachment #242334 - Flags: second-review?(jminta) → second-review?(dmose)
Attachment #242334 - Flags: second-review?(dmose)
Patch landed on MOZILLA_1_8_BRANCH and trunk (for testday)

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.