Images with links positioned relatively inside a <div> with absolute positioning fails

RESOLVED DUPLICATE of bug 102695

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 102695
11 years ago
11 years ago

People

(Reporter: Jahn Otto Næsgaard Andersen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

I have an area with a given size on screen. I want to have an area with images that are positioned relative to this area. I put images that are positioned with css within this area. Those images have a link. When I try this, the image that has been moved is no longer clickable.

I'm not sure if I'm doing something wrong or if this is a Firefox bug, but this works in IE. 

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.jotto.no/~jotto/firefoxissue.html
2. Try to click the image to the right
3. Try the same with IE or Opera
Actual Results:  
Second image is not clickable

Expected Results:  
Second image should be clickable

What I'm actually trying to do is to have a map with icons that are moving around. The positions of the icons are fetched from a server using JavaScript/AJAX.
Your problem is that the second absolutely positioned div is placed on top of the first. Firefox does not pass events through layers in this way.


*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
I see. Thanks!

Is there any other way to position a number of images relative to a <div> without having them interfere each other?

If I put all the <img> in the same <div>, the position of the images will be offset by the preceding images.

(I realize that this is not a css help forum. If there is no easy way to solve this, I'll ask in such a forum)
You need to log in before you can comment on or make changes to this bug.