Last Comment Bug 356882 - Flash Causes Crash After Blocked Popup Message
: Flash Causes Crash After Blocked Popup Message
Status: RESOLVED DUPLICATE of bug 304370
: crash
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.unixguide.net/linux/linuxs...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 15:47 PDT by Flummox
Modified: 2006-10-26 14:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Flummox 2006-10-16 15:47:39 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061016 BonEcho/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061016 BonEcho/2.0

Using the specified URL the popup blocked message must appear before a crash will occur.
Using www.supportsoft.com the crash happens 100% of the time with no popup blocked message.
The crash only happens for me using Mandriva 2007 - I cannot reproduce it using Mandriva 2006

The command line shows:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 120 error_code 8 request_code 146 minor_code 3)


Reproducible: Always

Steps to Reproduce:
1.Reload the URL until a 'popup blocked' message appears.
2.Crash
Comment 1 Flummox 2006-10-20 08:59:25 PDT
This seems to be Flash related.
Fresh Branch and Trunk Nightly builds with a new profile only crash when either Flash 7 or 9 beta are installed.
www.answers.com crashes despite having no popups.
The bug has also been mentioned on http://mandrivausers.org
Comment 2 Adam Guthrie 2006-10-26 14:02:24 PDT

*** This bug has been marked as a duplicate of 304370 ***

Note You need to log in before you can comment on or make changes to this bug.