de-hibernation infinite loop of firefox, mozilla, netscape

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: atlantisician, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Problem applies to:
- XP-home & XP professional
- Firefox (all versions), Mozilla & Netscape 7.2 and earlier
- IBM, Fujitsu, Dell, HP, etc. machines
When one of these browsers (or a combination of them) is used when one stops the machine via hibernation then one has a fair chance that they enter infinite loops when the machine is de-hibernated.  If so they will consume all cpu cycles and on older machines it may take upto 15 minutes before the user gets control back of the machine - obviously then squashing the run away processes in the Task Manager.

Reproducible: Sometimes



Expected Results:  
Perhaps the browser processes are not always stopped properly; perhaps their saved info gets damaged by MS; perhaps they recover erroneously.  Who knows?
Perhaps it is caused by defective disclosure by MS about hibernation.
And if one is paranoid enough this could be deliberate ....

I have reported this problems >>>for years<<< to different vendors, but they do not want to deal with it.  They are only willing to deal with IE problems  ....

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213637
atlantisician, this is more probably fixed by bug 376643, which should appear in FF 2.0.0.8.  When you get 2.0.0.8 if your problem is gone please dupe to 376643 and if problem persists please add a comment to the bug.

(IOW this is not a dupe of bug 213637)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
I run 2.0.0.11 and the bug still persists on an XP prof IBM Thinkpad - sometimes it takes more than 15 minutes for the machine to de-hibernate.

Closing FF before hibernation "solves" the problem here...

This is definitely not a dupe of bug 213637

Comment 4

12 years ago
Tried Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007121905 Minefield/3.0b3pre

Same behaviour, wake up from hibernate took more than 4 minutes (was the third or fourth wakeup after first start)
thanks for testing trunk.  I would not be suprised by 1-2 minutes for _FF_ to become responsive - I get remote desktop into my PC to come out of sleep: ~30 windows, ~5-10 tabs each

questions:
- is 4 minutes with trunk better than what you get with v2?
- was it just 1 out of 4 wakeups where this occurred?
- what is firefox's peak memory usage when you hibernate?  #tabs & #windows?
- how much memory on your PC?
- do some pages have flash images?  what version flash player from about:plugins?  (see bug 265172)


atlantisician?  any news?

Comment 6

12 years ago
Well, it takes 4 minutes to reach the login screen...it takes only seconds when FF is closed before hibernation. Not happy with that.

Your questions...
- looks like the same behaviour as in 2.0.0.11, the time gets longer and longer with every hibernation. First wake up goes fairly quick.
- see above, it's a slow decay of startup performance I'm experiencing
- hard to say, between 50 and 80 megs
- 512 MB
- Yes, brand new 9.0 r115, so it must be a different problem here. FFs system usage is often steadily above 30% before hibernate (it's a four year old R32 notebook with 2 GHz Northwood Mobile CPU), don't know if this is helpful
I'm not familiar with R32, used several T40 and T41 which are similar.

so in summary:
* each resume from hibernate takes longer
* essentially no new activity on FF between the hibernates
* FF memory usage far below system RAM

I would expect FF to *directly* affect time to get to login.  my gut reaction, based on 4 minutes to LOGIN, is disk issue compounded by FF memory usage.  what else do you have running when you go to hibernate (including virus protection, etc)? 

Also, do you see the problem if you have only about:blank empty FF windows?

Comment 8

12 years ago
concerning "takes longer", this is not quantified, just my "wind chill factor". The box ist used once daily for approx 4 hours for surfing, email, some web design and office. It seems to take longer to recover from hibernate after some days until it reaches a point when I have to turn the box off in the startup phase. FF has 4 to 7 open tabbed windows when going into hibernate.

In the startup phase (screen is blank and black after reading the hiberfil.sys) there is only few and short disk action (roughly 10% of the time), no pattern recognizable (doesn't look like looping).

Software that is running, umh, avast virus protection, apache 2.0.48, Klipfolio rss, open office resident, sometimes VNC viewer (doesn't matter if or if not), X-lite, Palm Hotsync, PGP tray.

I'll check on the about:blanks
(In reply to comment #7)
>...
> I would _NOT_ expect FF to *directly* affect time to get to login.  

I missed the word NOT above bug 352457 "Long wake-up after hibernate while firefox is running" described a similar issue, and is now WFM - he writes: "Now I have new computer. It's on Vista now. So I download firefox 3 beta. It work's fine."


(In reply to comment #8)
>..
> Software that is running, umh, avast virus protection, apache 2.0.48, Klipfolio
> rss, open office resident, sometimes VNC viewer (doesn't matter if or if not),
> X-lite, Palm Hotsync, PGP tray.
> 
> I'll check on the about:blanks

so you have a ton of stuff running. what email program is running when you shut down? what is page file size on disk?

Comment 10

12 years ago
Thunderbird 2.0.0.9
Page file is roughly 500 megs
Reporter

Comment 11

12 years ago
Someone asked me about my current experiences:
Good news: No problems anymore with 2.0.0.11 on my hp nx6110 XP professional 1GB laptop

Less good news: Still intermittent problems (I believe) with my ibm R31 XP home 512MB laptop.

I have been using often the sledgehammer of killing the FF process through the TaskManager before hibernating the machine.  After dehibernating one obtains the same state by starting FF and accepting a restore.  Even with 11 FFs and many, many tabs this kludge works OK.

I did notice (via this kludge) that FF leaks quite a lot of memory.

And here another gripe: I changed on my sites the favicon.ico files.  The personal toolbar does NOT recognize the new versions .... 

Comment 12

12 years ago
So far the about:blank FF doesn't slow down re-hibernating (up to 5 about:blank tabs open when hibernating) - so it seems content related.

Anything on
www.heise.de/newsticker
http://www.gocomics.com/calvinandhobbes/
http://www.elchfans.de/wbb2/index.php
http://www.kicker.de

(which are the most frequent pages that are open during hibernation) except for the flash animations that could lead into performance problems for FF?

The FF-killing in #11 works for me too...
1. www.heise.de/newsticker
2. http://www.gocomics.com/calvinandhobbes/
3. http://www.elchfans.de/wbb2/index.php
4. http://www.kicker.de

1 - primarily text page with one small animated gif - nothing special
3 - a tiny page with nothing notable 
1 & 4 - both with flash images, 4 is big

A. hibernate with just one of these at a time to narrow it down
B. with 1&4 install flashblock extension to keep the flash images from displaying, and see if that improves the time to resume from hibernate
C. does sleep/suspend to ram have a similar problem?

Comment 14

12 years ago
I now have a kind of confidence concerning the slow boot on my machine.

It's the Flash animation from #4. Both leaving #4 on about:blank and the rest running as well as using the Flashblock add-on proved to have a quick recovery from hibernation.
The Flash from #2 doesn't seem to affect boot up time.

Does this mean that bug 265172 has to be reopened?

Comment 15

11 years ago
On windows XP home firefox 2.0.12 does never restart the proxy connection-
Tracing with winshark not the smalest IP package is logged.
May I assume FF "thinks" is has a valid proxy connection bad has no anymore?

After killing FF via task manager (or killtask?)
FF can be restarted and reconnects flawlessly to all sites.

I found no dependency related to sites open while hibernation.

I saw that effect with the FTD (finacial times deutschland) screen 
saver too.

In times of C02 saving it is very, em, "strange" (?) when an OS product 
do not support enery saving with hibernating. ("standby" not tested).

The problem might be XP home specific.

 

Comment 16

11 years ago
On windows XP home firefox 2.0.12 does never restart the proxy connection-
Tracing with winshark not the smalest IP package is logged.
May I assume FF "thinks" is has a valid proxy connection bad has no anymore?

After killing FF via task manager (or killtask?)
FF can be restarted and reconnects flawlessly to all sites.

I found no dependency related to sites open while hibernation.

I saw that effect with the FTD (finacial times deutschland) screen 
saver too.

In times of C02 saving it is very, em, "strange" (?) when an OS product 
do not support enery saving with hibernating. ("standby" not tested).

The problem might be XP home specific.

 

Comment 17

11 years ago
Pardon, should read:
May I assume FF "thinks" is has a valid proxy connection but has no at all anymore?

Comment 18

11 years ago
Pardon, should read:
May I assume FF "thinks" is has a valid proxy connection but has no at all anymore?
hmm, what is status use firefox 3?
Reporter

Comment 20

11 years ago
Have not seen this problem for a long time on Compaq nx6110/ XP professional sp3.

Tested on IBM Thinkpad R31 XP home sp3 and cannot replicate the problem either with 3 dehibernations.

I use FF 3.0.5 these days.
Since it was an intermittent problem, it is difficult the claim that it is now
solved ....
if you haven't seen this since FF3 came out 5 months ago I think closing this bug WFM is very reasonable.

Bugzilla@ZocKi.Toppoint.DE and Uwe if you still see this problem using FF3 and flash 10 then you will want to file a new bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME

Comment 22

11 years ago
WFME!

With Flashblock I haven't had any problems on any of my machines here.
You need to log in before you can comment on or make changes to this bug.