Closed Bug 356916 Opened 13 years ago Closed 12 years ago

DOM Inspector not working for Thunderbird - Projects should sync

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254031

People

(Reporter: BijuMailList, Unassigned)

References

Details

On Thunderbird version 3 alpha 1 (20061016) on WinXP

I made
  extensions.checkCompatibility = false
  extensions.disabledObsolete = false
and installed dom_inspector-1.8-tb-windows.xpi 

But still DOM Inspector is not working.

I get following on error console

==== Error 1 ====
No chrome package registered for chrome://browser/content/baseMenuOverlay.xul .

==== Error 2 ====

Warning: Failed to load overlay from chrome://browser/content/baseMenuOverlay.xul.
Source File: chrome://inspector/content/inspector.xul
Line: 0

============

IMHO: 
1. 
DOM Inspector Extension and Thunderbird Projects should 
synchronize the development process. 
Or DOM Inspector should lead, to incorporate the changes in TB

2.
DOM Inspector Ext should be tested before every TB/Fx/Mz nightly.
Severity: normal → major
you aren't entitled to your own opinion unless you contribute patches.
(In reply to comment #1)
> you aren't entitled to your own opinion unless you contribute patches.

sad...

Any body working on this?

Any way I removed ref to baseMenuOverlay.xul
from chrome://inspector/content/inspector.xul

Now when inspecting Thunderbird window, 
in chrome://inspector/content/viewers/dom/dom.js
at line:  80
ie, statement: this.mDOMView = XPCU.createInstance(kDOMViewCID, "inIDOMView");

I get "null" for this.mDOMView !!!!

kDOMViewCID (a const)is initialized as "@mozilla.org/inspector/dom-view;1";

Any suggestion, how to fix?
You need to build your own Thunderbird, with 
ac_add_options --enable-inspector-apis

The inspector APIs are disabled by default in the mail client.

It would be nice if there was an unofficial developer's build somewhere, with DOM inspector + venkman.
(In reply to comment #0)

> ==== Error 1 ====
> No chrome package registered for chrome://browser/content/baseMenuOverlay.xul .
> 
> ==== Error 2 ====
> 
> Warning: Failed to load overlay from
> chrome://browser/content/baseMenuOverlay.xul.
> Source File: chrome://inspector/content/inspector.xul
> Line: 0

Both fixed with Bug 327833.

> IMHO: 
> 1. 
> DOM Inspector Extension and Thunderbird Projects should 
> synchronize the development process. 
> Or DOM Inspector should lead, to incorporate the changes in TB

DOMI is developed on its own.

> 2.
> DOM Inspector Ext should be tested before every TB/Fx/Mz nightly.

You are more than welcome to watch the user "dom-inspector@extensions.bugs" and test patches, but generally they will only be tested on browser and suite.
Severity: major → normal
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Depends on: 271812
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
This was fixed in bug 254031.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254031
You need to log in before you can comment on or make changes to this bug.