No image shown when URI for img tag href attrtibute contains two dots before extension

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: Paul Cormier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I noticed that when an IMG tag references a URI with two dots (periods) in the href attribute, the referenced image is not rendered.

Reproducible: Always

Steps to Reproduce:
1. Create an HTML page which contains an IMG tag whose href points to an image file matching the pattern: /.*\.\.jpg/
2. View the page in Firefox 1.5.0.7, note that the image is not rendered.
3. Confirm that another browser (IE6 for example) does render the image.

Actual Results:  
No image is rendered in Firefox.  Images were rendered as expected in IE6.

Expected Results:  
I expected the browser to render the images similarly to IE6.

Firefox was able to view the images directly when 'View Image' was selected from the context menu.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
http://gavinsharp.com/tmp/356965.html loads fine for me, using both 1.5.0.7 and a recent Firefox 2 branch build.

Could you provide a testcase that shows the problem?
Version: 1.5.0.x Branch → unspecified
(Reporter)

Comment 2

12 years ago
Created attachment 242642 [details]
A testcase for this bug.

Image files to follow.
(Reporter)

Comment 3

12 years ago
Created attachment 242643 [details]
Image 1
(Reporter)

Comment 4

12 years ago
Created attachment 242644 [details]
Image 2
(Reporter)

Comment 5

12 years ago
Created attachment 242645 [details]
Image 3
(Reporter)

Comment 6

12 years ago
I added a test case, and tested the scope of the problem.
It only seems to be the case that when the URI is an absolute path to a local file in the form 'c:\folder\maybe another folder\image..jpg'.  'file:///c:/' and relative URIs work fine.
(Reporter)

Comment 7

12 years ago
Upon furthur inspection...

The two dots in the URI are irrelevant to the problem, Firefox doesn't render any images specified with platform specific absolute URIs.

Sorry for the trouble.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Thanks for following up :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.