default printer not honored after using PDFcreator

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: ToddAndMargo, Unassigned)

Tracking

2.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

Hi All,

   Every time I print to PDFcreator (http://http://sourceforge.net/project/showfiles.php?group_id=57796&package_id=53473&release_id=442172), I have to
go into prefs.js and remove the following line:

user_pref("print.print_printer", "PDFCreator");

Otherwise, it becomes my NEW default printer for Firefox.
Most annoying.

-T

Reproducible: Always

Comment 1

13 years ago
With windows apps in general, I believe the default printer is the last used in that app since current instance opened.  If none used for this instance then use system default.  Is that not what's happening here?

Does Firefox behave differently if a different printer is the last used? (i.e. it does revert for a different printer)

Will try to repro on Windows tonight.

btw, this is Win2k, right?


(In reply to comment #0)
>    Every time I print to PDFcreator
> I have to
> go into prefs.js and remove the following line:
> 
> user_pref("print.print_printer", "PDFCreator");
> 
> Otherwise, it becomes my NEW default printer for Firefox.
(Reporter)

Comment 2

13 years ago
This is w2k-pro, service pack 4, roll up patch 1.  Firefox
is 2.0 rc2 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0))

My default printer is set to my Okipage.

After printing to PDFCreator, it does not matter where I print to.
Firefox still defaults to the PDFCreator.  I have tried printing to 
the Okipage, exiting FF, then restarting: it goes right back to
PDFCreator

Amewell, Do you still see thee problem?
I'd be surprised if this is problem is caused by Firefox.
What does the vendor, or other users say?
 http://www.foxitsoftware.com/bbs/forumdisplay.php?f=13
see also
 For help: http://forums.mozillazine.org/
 bug 358449
Severity: normal → minor
Version: unspecified → 2.0 Branch
not firefox => invalid
also, reporter "... no longer have the facilities to test this (switched to Linux)."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.