keep longer MRU list of "Create In" bookmark folders

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: bugsubmitter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I'd really like a much longer list of recently used folders when adding a new bookmark. the dropdown list. The "Create in" dropdown has it's first entry as Bookmarks, then Bookmarks Toolbar, then a divider and five remember last folders that items were saved to. It's been a limitation of firefox that's bugged me for the several years I've been using it. And my folder hives can get pretty deep, and often I will be saving to the same folder for a couple of days as I learn about something....but with only five folders in the recently used list, often the most needed folders have to be relocated in the hive.

There is an extension called OpenBook, but it doesn't adjust the MRU list; and the dev of the ext says it'd be hard or impossible to do as an extension.

Reproducible: Always

Comment 1

10 years ago
i'm not sure a longer list would be useful, could clutter the ui, the folder picker is a click later and offers all folders.
Summary: keep longer history of "Create In" bookmark folders → keep longer MRU list of "Create In" bookmark folders
Whiteboard: WONTFIX?
this is not a common request, and this bug has no dupes, and i agree with comment #1: it's cluttery, and there's a valid workaround, so marking WONTFIX.

marco, can you recommend a way for an extension developer to do this if possible? otherwise, i recommend filing a bug requesting that UI be easier to extend.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: WONTFIX?

Comment 3

10 years ago
(In reply to comment #2)
> marco, can you recommend a way for an extension developer to do this if
> possible? otherwise, i recommend filing a bug requesting that UI be easier to
> extend.

mh the number of results is defined in const MAX_FOLDER_ITEM_IN_MENU_LIST, in editBookmarkOverlay.js. I can't see an easy way to override that.
You need to log in before you can comment on or make changes to this bug.