Some downloads completely lock up the entire computer

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: firefox, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Certain links will cause the entire computer to lock up for different lengths of time. E.g. the above link locked up this computer for 30 minutes even though the file size is under 19 MB and I have a 100 Mbps broadband connection. I can't currently remember other links that show this but I could add to this bug report as I encounter them. This occurs too often for comfort.

It seems like those links that cause this behavior are first downloaded in their entirety before the save dialog is popped up even though I have download managers installed (DownThemAll and Getright) because if I choose "Save file" at the end of it the download finishes immediately. In the meantime everything on the computer just freezes. And it doesn't seem like there is actually any actual CPU load happening, just that everything simply freezes. I suspect the initial reason might be that the machine serving the link fails to send a proper content header for those files that somehow cause the browser to go into some waiting state. That is bad enough, but why the lock up of the entire OS?

This seems to be happening only on Windows. I use Firefox quite extensively on Solaris as well and have not seen this behavior there. (Or is it simply that the Solaris multitasking capabilities are so much better than Windows'.)

This has been happening for some time. I just installed Firefox 2.0 RC3 and discovered that it's still there.


Reproducible: Always

Steps to Reproduce:
1. Use Windows XP SP2
2. Point Firefox to "http://appldnld.apple.com.edgesuite.net/qtinstall.info.apple.com/mcgonagail/us/win/QuickTimeInstaller.exe"
3. Sit and wait until the file is completely downloaded before the OS to start responding again.

Actual Results:  
Computer freezes for approx 30 minutes until the file is completely downloaded

Expected Results:  
The download manger dialog box popping up letting me choose what to do with the file *about to be* downloaded.

Currently using theme SphereGnome 2.0. Will try the default theme after I submit this report.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061016 BonEcho/2.0

Works for me. Please try cleaning up your download manager or delete the file downloads.rdf in your profile.
http://kb.mozillazine.org/Profile_Folder
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
The proposed solution works. I get the download dialog immediately afetr deleting "downloads.rdf".

However, there was only one entry in the download manager list before I deleted "downloads.rdf". And removing that one entry with the clean up button didn't help matters whatsoever. Only after deleting the actual file in the profile it works as expected.

This can hardly be proper behavior. And this problem has been around for years. Shouldn't there be a proper bugfix instead of this hands on remedy each time the browser locks up the entire computer when certain downloads are started?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: unspecified → 2.0 Branch
Problems like this are very common. I think they are in the top 10 problems on the Mozillazine forums, as all profile files can get corrupted sooner or later.
In case someone would want to analyse the corruption, you could attach the downloads.rdf file to this bug. 
No response from reporter about attaching corrupt downlods.rdf.. this file is going all sqlite on us anyway -->WORKSFORME.
Reporter, if you still see this problem with Firefox 2 please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.