Startup option to open Mail & Newgroups first and then navigator for future instance of seamonkey starts

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: jstark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061011 SeaMonkey/1.1b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061011 SeaMonkey/1.1b

My Appearance settings only have 'Mail & Newsgroups' ticked.

Before Upgrade (Sm 1.1b Build 20060919) :
When I run Seamonkey for the first time it opens my mail and news reader, then if I run seamonkey again from command line or quick launch bar, it will open a navigator window and continue to do so for each future time I run seamonkey.

After Upgrade (Sm 1.1b Build 20060111):
When I run Seamonkey for the first time it opens my mail and news reader, then if I run seamonkey again from command line or quick launch bar, it will open another Mail & Newsreader window. It will not open the browser window. This is the case if I run seamonkey from command line, click on the quick launch, click on my start menu bar for 'Internet'.

The only way I am able to open a navigator window is a 'Ctrl-N' in the current mail window, or to run 'seamonkey -broswer' from a command line.

Reproducible: Always

Steps to Reproduce:
1. Set Appearance settings to open only Mail & Newsgroups
2. Close all seamonkey windows
3. Open seamonkey via, start menu or desktop icon or quick launch.
  - you will get a mail window open now
4. Open seamonkey the same way as in step 3.
  - You should have a browser (navigator) window, but I get another mail window.
Actual Results:  
You will have two mail & Newsgroups windows open

Expected Results:  
You should get the Mail & Newsgroups with the first time it opens and then a browser the second time you open seamonkey

This worked fine before the upgrade on Sm 1.1b Build 20060919 and is now broken since installing Sm 1.1b Build 20061011
(Reporter)

Comment 1

12 years ago
Workaround:

- Untick all options in "When SeaMonkey starts up, open"
- Set SeaMonkey as default Browser and Email client in Windows.
- Use options on start menu bar in windows to open either browser or email.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.