It cannot import properly the MIME stuff from previously saved .eml !!!

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
12 years ago
12 years ago

People

(Reporter: damoks, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9)
Build Identifier: Thunderbird - verzió 1.5.0.7 (20060909) (theres no id like mozilla/5.0....)

Ive did a pretty nice html/mime type mail with a tons of pics (check attached pic) then saved to a .eml file (file on the same url /dl/message1.eml) to bring it to my work, but when ive did a reload (tried at my work then at home on the same pc) ive got the pictures attached but not placed, maybe thunderbird cannot retrive the saved informations properly, because i can see that the eml file contains all of the images, but cannot handle them... maybe the same could happens when i try to send to another user, i mean thunderbird cannot READ its own stuff... it this a very buggy release? Or just what i have to do, because i have to send this stuff today!

please help me to hack my .eml file to be able to send it forward properly!!!

Reproducible: Always

Steps to Reproduce:
1. Create a new mail, place some images with some text.
2. Save as draft and then go to the drafts folder view, and select Save As/File and save as a mail into .eml file
3. Go File/open mail and select the previously saved file to open

Actual Results:  
you will get the mail with the html tags properly, but without the pictures, because it only show as attached images.

Expected Results:  
Maybe its an optional field, i think the prog have to handle its mime type stuff properly...

Theres no theme or other stuff installed, its a native properly installed hungarian thunderbird release, but i think its a thunderbird release bug, not in only hungarian releases.

Comment 1

12 years ago
In order to determine what your problem is, we need to see the actual message.
You can attach the .EML file to the bug using the Create New Attachment link above.  However, the screenshot you show implies that the message is very large; if you can create a smaller example and attach that instead, it would be better.

It might be simpler if you'd try a nightly build or the 2a1 prerelease -- there was some work done to fix a similar symptom (see bug 355382).  If a 2x build doesn't show the problem, please mark this bug:   Resolved | WorksForMe
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
Now tried thunderbird nightly release build 3.0a1, the problem "partially" solved,  so it can import .eml file properly. But if im going to Edit message as new (ctrl+e), or just trying to forward the email, the images are absolutely GONE, and theres no attachments...

Comment 3

12 years ago
(In reply to comment #2)
> But if im going to Edit message as new (ctrl+e), or just trying to forward
> the email, the images are absolutely GONE, and theres no attachments...

That's a known problem: bug 351109.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.