Crash if I try to execute under a clean linux install only with Athlon Thunderbird CPU

RESOLVED DUPLICATE of bug 313160

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 313160
12 years ago
12 years ago

People

(Reporter: Sandro Beni, Unassigned)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I experienced this problem only on a PC equipped with Athlon Thunderbird CPU.
Running this PC with MS Windows XP everithing works fine (Firefox too), but if I try to execute firefox after a clean linux installation, the program crash.
I tried with the following distros: Knoppix 5.01 (live CD), Ububtu 6.06 LTS (both live and install with latest patches/updates), Fedora Core 3 and Fedora Core 4.
I got this problem even if I try to create a virtual machine with Linux under VmWare.
The only PC I experienced this problem is equipped with the following CPU (I got the output from cpu-z 1.37)


  Name .........: AMD Athlon
  Code Name ....: Thunderbird
  Brand ID .....:
  Package ......: Socket A (462)
  Technology ...: 0.18um
  Voltage ......: 3.038 v
  Specification : AMD Athlon(tm) Processor
  Family .......: 6
  Model ........: 4
  Stepping .....: 4
  Ext. Family ..: 7
  Ext. Model ...: 4
  Revision .....: A9
  Instructions .: MMX(+), 3DNow!(+)

Last try I made, is to debug this crash under a VmWare virtual machine running Ubuntu 6.06LTS with latest updates. I follow the instructions found there https://wiki.ubuntu.com/DebuggingFirefox, and this is the output I got from debugger:

  workstation@Ubuntu:~$ firefox -g 2>&1 | tee gdb-firefox.log
  GNU gdb 6.4-debian
  Copyright 2005 Free Software Foundation, Inc.
  GDB is free software, covered by the GNU General Public License, and you are
  welcome to change it and/or distribute copies of it under certain conditions.
  Type "show copying" to see the conditions.
  There is absolutely no warranty for GDB.  Type "show warranty" for details.
  This GDB was configured as "i486-linux-gnu"...Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".

  (gdb) run
  Starting program: /usr/lib/firefox/firefox-bin -a firefox
  [Thread debugging using libthread_db enabled]
  [New Thread -1220430144 (LWP 6439)]
  [New Thread -1223083088 (LWP 6444)]

  Program received signal SIGSEGV, Segmentation fault.
  [Switching to Thread -1220430144 (LWP 6439)]
  0xb7e74278 in JS_dtostr (
      buffer=0xbf7fd06e "��214750003399999999507889149507789901631653259690663218163288630396127391274530483373560269547594226415841191966004367905816629150406903764601826629596945270659353613770659652344435169187179950752701"..., bufferSize=26,
      mode=DTOSTR_STANDARD, precision=<value optimized out>, d=2147500034) at jsdtoa.c:2393
  2393    jsdtoa.c: Nessun file o directory.
          in jsdtoa.c
  Current language:  auto; currently c
  (gdb)

I never had any problem like this using different PCs and CPUs, and I cannnot try to reproduce the problem using another PC with AMD Athlon Thunderbird CPU.


Reproducible: Always

Steps to Reproduce:
1.install a clean linux ubuntu 6.06lts on a pc equipped with athlon thunderbird cpu
2.try to execute firefox from bash console

Actual Results:  
you got a segmentation fault error and firefox doesn't start


Expected Results:  
firefox starting

As I said before, I suppose the crash is because of my CPU (maybe some kind of optimization my CPU doesn't like). I know this kind of CPU is not easy to retrieve to perform needed tests, but I'll be very happy to give my support for every kind of needed tests.

Comment 1

12 years ago
Next time it happens, can you try getting a stacktrace using the steps outlined here: http://kb.mozillazine.org/Getting_a_stacktrace_with_gdb ?
Keywords: crash, stackwanted

Comment 2

12 years ago
bug 313160?

*** This bug has been marked as a duplicate of 313160 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
for Adam Guthrie: I just post the stacktrace you request as a comment for bug #313160 (marked as a duplicate of this bug)
You need to log in before you can comment on or make changes to this bug.