collectstats failed due to duplicates.cgi: Use of uninitialized value in string ne at (eval 57) line 31.

RESOLVED WORKSFORME

Status

()

Bugzilla
Reporting/Charting
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Jack Yu, Assigned: gerv)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; InfoPath.1)
Build Identifier: 2.22

When run collectstats.pl in either crontab or shell, it returned error message

bug# ./collectstats.pl
[Wed Oct 18 11:22:33 2006] duplicates.cgi: Use of uninitialized value in string ne at (eval 57) line 31.




Reproducible: Always

Steps to Reproduce:
1../collectstats.pl
2.
3.

Actual Results:  
[Wed Oct 18 11:22:33 2006] duplicates.cgi: Use of uninitialized value in string ne at (eval 57) line 31.


Expected Results:  
no error message

bug# ./checksetup.pl

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.56
Checking for             CGI (v2.93)   ok: found v3.16
Checking for    Data::Dumper (any)     ok: found v2.121
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.38)   ok: found v1.50
Checking for      File::Spec (v0.84)   ok: found v3.16
Checking for      File::Temp (any)     ok: found v0.16
Checking for        Template (v2.08)   ok: found v2.14
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929
Checking for    Mail::Mailer (v1.67)   ok: found v1.74
Checking for    MIME::Base64 (v3.01)   ok: found v3.07
Checking for    MIME::Parser (v5.406)  ok: found v5.420
Checking for        Storable (any)     ok: found v2.15

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.30
Checking for     Chart::Base (v1.0)    ok: found v2.3
Checking for       XML::Twig (any)     ok: found v3.23
Checking for       GD::Graph (any)     ok: found v1.4305
Checking for GD::Text::Align (any)     ok: found v1.18
Checking for     PatchReader (v0.9.4)  ok: found v0.9.5
Checking for   Image::Magick (any)     ok: found v6.2.5

Checking user setup ...
Removing existing compiled templates ...
Precompiling templates ...
Checking for      DBD::mysql (v2.9003) ok: found v3.0002
Checking for           MySQL (v4.0.14) ok: found v4.1.18



Here are all the packages in my system

ImageMagick-6.2.5.5_3 Image processing tools
apache-2.2.3        Version 2.2 of Apache web server with prefork MPM.
autoconf-2.59_2     Automatically configure source code on many Un*x platforms
bash-2.05b.007_4    The GNU Bourne Again Shell
bison-1.75_2,1      A parser generator from FSF, (mostly) compatible with Yacc
bsdpan-MIME-tools-5.420 MIME-tools - modules for parsing (and creating!) MIME entit
bsdpan-MailTools-1.74 Mail::Cap - Parse mailcap files
bugzilla-2.22       Bug-tracking system developed by Mozilla Project
expat-2.0.0_1       XML 1.0 parser written in C
fontconfig-2.3.2_3,1 An XML-based font configuration API for X Windows
freetype2-2.1.10_3  A free and portable TrueType font rendering engine
gd-2.0.33_4,1       A graphics library for fast creation of images
gettext-0.14.5_2    GNU gettext package
ghostscript-gnu-7.07_15 GNU Postscript interpreter
gmake-3.80_2        GNU version of 'make' utility
graphviz-2.6_4      Graph Visualization Software from AT&T and Bell Labs
gsfonts-8.11_2      Fonts used by GNU Ghostscript (or X)
gzip-1.3.5_2        A compression utility designed to be a replacement for comp
help2man-1.36.3     Automatically generating simple manual pages from program o
imake-6.9.0         Imake and other utilities from X.Org
jasper-1.701.0_1    An implementation of the codec specified in the JPEG-2000 s
jbigkit-1.6         Lossless compression for bi-level images such as scanned pa
jpeg-6b_4           IJG's jpeg compression utilities
lcms-1.14_1,1       Light Color Management System -- a color management library
libdrm-2.0_1        Userspace interface to kernel Direct Rendering Module servi
libfpx-1.2.0.12     Library routines for working with Flashpix images
libiconv-1.9.2_2    A character set conversion library
libltdl-1.5.22      System independent dlopen wrapper
libtool-1.5.22_2    Generic shared library support script
libxml2-2.6.23_1    XML parser library for GNOME
m4-1.4.4            GNU m4
mpeg2codec-1.2_1    An MPEG-2 Encoder and Decoder
mysql-client-4.1.18_1 Multithreaded SQL database (client)
mysql-server-4.1.18_2 Multithreaded SQL database (server)
openldap-client-2.2.30 Open source LDAP client implementation
p5-AppConfig-1.56   A Perl module for reading configuration files
p5-Authen-SASL-2.09 Perl5 module for SASL authentication
p5-Bit-Vector-6.4_1 Library of advanced math functions that includes a Perl OO
p5-CGI.pm-3.16,1    Simple Common Gateway Interface Class for Perl
p5-Carp-Clan-5.3    Report errors from perspective of caller of a "clan" of mod
p5-Chart-2.3        A perl5 interface to build chart graphics
p5-Compress-Zlib-1.41 Perl5 interface to zlib compression library
p5-DBD-mysql-3.0002 MySQL driver for the Perl5 Database Interface (DBI)
p5-DBI-1.50         The perl5 Database Interface.  Required for DBD::* modules
p5-Data-Dumper-2.121 Stringified perl data structures, suitable for both printin
p5-Date-Calc-5.4    Gregorian calendar date calculations
p5-Digest-1.14      Modules that calculate message digests
p5-Digest-MD5-2.36  Perl5 interface to the MD5 algorithm
p5-File-Temp-0.16_4 Perl5 module to generate temporary files or directories saf
p5-GD-2.30          A perl5 interface to Gd Graphics Library version2
p5-GD-Graph-1.43.05 Graph plotting module for perl5
p5-GD-Graph3d-0.63  Creates 3D charts with GD::Graph and GD
p5-GD-TextUtil-0.86 Text utilities for use with GD drawing package
p5-HTML-Parser-3.50 Perl5 module for parsing HTML documents
p5-HTML-Tagset-3.10 Some useful data table in parsing HTML
p5-HTML-Tree-3.19.01 A collection of modules to manupulate HTML syntax trees
p5-IO-String-1.08   Simplified Perl5 module to handle I/O on in-core strings
p5-IO-stringy-2.110 Perl5 module for using IO handles with non-file objects
p5-Image-Info-1.17  Perl module for getting image information
p5-Image-Size-2.992 Perl5 module to determine the size of images in several com
p5-MIME-Base64-3.07 Perl5 module for Base64 and Quoted-Printable encodings
p5-Net-1.19,1       Perl5 modules to access and use network protocols
p5-PatchReader-0.9.5 Perl module with utilities to read and manipulate patches a
p5-PathTools-3.16   A Perl module for portably manipulating file specifications
p5-Pod-POM-0.17     POD Object Model
p5-Scalar-List-Utils-1.18,1 Perl subroutines that would be nice to have in the perl cor
p5-Storable-2.15    Persistency for perl data structures
p5-Template-Toolkit-2.14_2 Extensive Toolkit for template processing
p5-Test-Harness-2.56 Run perl standard test scripts with statistics
p5-Test-Simple-0.62 Basic utilities for writing tests in perl
p5-Text-Autoformat-1.13 Automatic and manual text wrapping and reformating formatti
p5-Text-Iconv-1.4   Perl interface to iconv() codeset conversion function
p5-Text-Reform-1.11 Manual text wrapping and reformatting
p5-Text-Tabs+Wrap-2001.0929 Line wrapping to form simple paragraphs
p5-Tie-DBI-1.01     Perl module implementing Tie hash to a DBI handle
p5-Tie-IxHash-1.21  Perl module implementing ordered in-memory associative arra
p5-TimeDate-1.16,1  Perl5 module containing a better/faster date parser for abs
p5-URI-1.35         Perl5 interface to Uniform Resource Identifier (URI) refere
p5-XML-DOM-1.44     Perl module for building DOM Level 1 compliant document str
p5-XML-Filter-BufferText-1.01 Filter to put all characters() in one event
p5-XML-Handler-YAWriter-0.23 Yet another Perl SAX XML Writer
p5-XML-NamespaceSupport-1.09_1 A simple generic namespace support class
p5-XML-Parser-2.34_2 Perl extension interface to James Clark's XML parser, expat
p5-XML-RSS-1.05_1   Perl extension to manage RDF Site Summary (RSS) files
p5-XML-RegExp-0.03  Regular expressions for XML tokens
p5-XML-SAX-0.13     Simple API for XML
p5-XML-SAX-Writer-0.44 SAX2 XML Writer
p5-XML-Simple-2.14  Trivial API for reading and writing XML (esp config files)
p5-XML-Twig-3.23    Process huge XML documents by chunks via a tree interface
p5-XML-XPath-1.13   Modules for parsing and evaluating XPath statements
p5-gettext-1.05_1   Message handling functions
p5-libwww-5.805     Perl5 library for WWW access
p5-libxml-0.08      Collection of Perl5 modules for working with XML
perl-5.8.8          Practical Extraction and Report Language
pkgconfig-0.20      A utility to retrieve information about installed libraries
png-1.2.8_3         Library for manipulating PNG images
python-2.4.2        An interpreted object-oriented programming language
tcl-8.4.11,1        Tool Command Language
tiff-3.8.0_1        Tools and library routines for working with TIFF images
tk-8.4.11,2         Graphical toolkit for TCL
unzip-5.52_2        List, test and extract compressed files in a ZIP archive
xorg-libraries-6.9.0 X11 libraries and headers from X.Org
*** Bug 357211 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
That's not a failure message. That's just a warning.

collectstats.pl doesn't print out anything when it succeeds, so it's probably succeeding.

Severity: major → normal
OS: Linux → All
Hardware: PC → All
Version: unspecified → 2.22

Comment 3

12 years ago
I don't understand what you are describing. How could collectstats.pl generate an error in duplicates.cgi?? Anyway, running both collectstats.pl and duplicates.cgi on 2.22.1 and 2.23.3 doesn't generate any warning.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Comment 4

12 years ago
These messages are usually due to perl-CGI (IIRC 3.15 and newer). Upgrade that to the latest version (from CPAN). Maybe it has been fixed.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> These messages are usually due to perl-CGI (IIRC 3.15 and newer). Upgrade that
> to the latest version (from CPAN). Maybe it has been fixed.

After upgrading the p5-CGI.pm from 3.16 to 3.25, this error message no long show up.

I think the fix for this is to upgrade the p5-CGI.pm to 3.25.
You need to log in before you can comment on or make changes to this bug.