If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hover effects are kinda broken

VERIFIED WORKSFORME

Status

()

Core
Widget: Cocoa
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: Josh Aas)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mouse events])

(Reporter)

Description

11 years ago
Steps to reproduce:
1. Launch Firefox.

or

1. Cmd+T.
2. Paste "http://www.squarefree.com/start/".
3. Press Enter.

Now hover over links, tabs, or items on the bookmarks toolbar.  For links, the cursor fails to turn into a hand, and for the chrome items, hover effects are missing.

After clicking in an empty area of the page, the problems (even for chrome) are fixed.

I suspect this is a regression from the switch to Cocoa, but there weren't any nightly builds for a week leading up to the switch to it's hard to tell.
(Reporter)

Comment 1

11 years ago
Another problem that happens at the same time: Cmd+clicking a link makes a drag indicator appear during the click, even if the cursor doesn't move at all.

Updated

11 years ago
Assignee: events → joshmoz
Component: Event Handling → Widget: Cocoa
QA Contact: ian → cocoa
Whiteboard: [mouse events]
(Assignee)

Comment 2

10 years ago
I can't reproduce this.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Cannot reproduce either, verifying.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

10 years ago
WFM here too.
You need to log in before you can comment on or make changes to this bug.