Defer Inbox to self leads to instability/crash

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: mcow, Unassigned)

Tracking

({crash})

1.8 Branch
crash
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ccbr])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Someone mentioned this in a newsgroup; I tried it and there does seem to be a problem:

Pick a POP account; in its Advanced settings, select "Inbox for different account" -- and then pick the account itself, which appears in the dropdown list (along with the other POP accounts, Local Folders, and, probably erroneously, any RSS accounts).  Accept changes, exit, restart.

The newsgroup reporter mentioned crashes.  I didn't see any crash right away, but I didn't try to fetch mail for the account either (I was using a test profile with an account set for a nonexistent server).  But as soon as I exited the program, it crashed (Talkback TB24773340Q).  This was using 2b1-1018, Win2K

The simple way to address this, it seems to me, is to prune the list of accounts presented in the dropdown.

Comment 1

12 years ago
yeah, I thought we prevented that somehow - we may not be able to prune it from the list, but we could at least put up an error.

Comment 2

12 years ago
I've confirmed this on a fresh installation (clean program directory and no legacy profiles) of 1.5.0.7 on XP, with a slightly different result: upon restart, the interface appears to start normally, though with no POP account on the folders pane, and then the crash occurs (Talkback 24778316).
(Reporter)

Updated

12 years ago
Flags: blocking-thunderbird2?
Both talkback incidents have expired so i can't post the stack sig.
Severity: major → critical
Keywords: crash
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

12 years ago
Moving off bugs that didn't make the deadline for Thunderbird 2. 
Flags: blocking-thunderbird2? → blocking-thunderbird2-
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
Tony, can you reproduce?

marking wanted? in case it still happens - sounds like it would be a simple fix (comment 1)
Flags: wanted-thunderbird3?
Tony, perhaps you see the same thing I do, and this can be downgraded.

1. Advance settings for account-A
2. set "inbox for different account" to account-A
3. click OK to close advanced settings
4. click OK to close settings
results: setttings won't close

5. click advanced settings
results: notice that "inbox for different account" is blank, and "inbox for this server's account" is selected
For crash, bug 379663 exists(Bug 388892 is DUP'ed to it).
For improvement of UI, bug 389139 exists(never offer myself).
Telmo writes

I'm still using Thunderbird. I followed the steps in the bug description, using one of my POP accounts, and, after clicking OK on the Advanced Account Settings dialog, clicking OK on the Account Setting dialog had no effect. I cancelled it and closed Thunderbird. Trying to start it again, it always crashed, even in safe mode. The Talkback thing sent out a few incident reports, probably all the same: TB54892211G, TB54892215H, TB54892221E, and TB54892227X. To set things right, I had to go to my profile, open prefs.js and comment out the line that set the "deferral" from the POP account to itself. Hope that helps...
Telmo, can you get talkback id again, using something newer than 2.0.0.4?  (2.0.0.23 is current).  Sorry, but the stacks of of comment 8 are gone
Keywords: stackwanted
Version: Trunk → 1.8 Branch

Comment 10

9 years ago
Created attachment 409601 [details]
Talkback incident that failed to be sent.

Comment 11

9 years ago
Comment on attachment 409601 [details]
Talkback incident that failed to be sent.

My Talkback agent always says it's "unable to connect to the server", so I'm attaching an incident's details as a text file.
Attachment #409601 - Attachment description: Talkback incident that failed to be sent. See comment #10. → Talkback incident that failed to be sent.
talkback as been down for a few days.  someone will post when it's back up

Comment 13

9 years ago
Similar incidents: TB56821109Y, TB56821110W.
(talkback is back up).  stack below.

deferring to wada/others for duping of bug, ...

ntdll.dll + 0x101b3 (0x7c9101b3)
msvcrt.dll + 0x1c3c9 (0x77c2c3c9)
msvcrt.dll + 0x1c3e7 (0x77c2c3e7)
msvcrt.dll + 0x19cd4 (0x77c29cd4)
orkinHeap::Alloc  [mozilla/db/mork/src/orkinHeap.cpp, line 91]
morkMap::new_keys  [mozilla/db/mork/src/morkMap.cpp, line 369]
morkMap::InitMap  [mozilla/db/mork/src/morkMap.cpp, line 249]
morkMap::morkMap  [mozilla/db/mork/src/morkMap.cpp, line 214]
morkRowMap::morkRowMap  [mozilla/db/mork/src/morkRowMap.cpp, line 94]
morkRowSpace::morkRowSpace  [mozilla/db/mork/src/morkRowSpace.cpp, line 133]
morkStore::LazyGetRowSpace  [mozilla/db/mork/src/morkStore.cpp, line 593]
morkStore::OidToTable  [mozilla/db/mork/src/morkStore.cpp, line 1308]
morkStore::MidToTable  [mozilla/db/mork/src/morkStore.cpp, line 798]
morkBuilder::OnNewTable  [mozilla/db/mork/src/morkBuilder.cpp, line 392]
morkParser::ReadTable  [mozilla/db/mork/src/morkParser.cpp, line 775]
Keywords: stackwanted
Summary: Defer Inbox to self leads to instability → Defer Inbox to self leads to instability/crash
Whiteboard: [ccbr]
Does Thunderbird 3 or Seamonkey 2 have this problem?

Comment 16

8 years ago
I've not been able to reproduce it with trunk builds, and don't think I've fixed anything in the area for quite a while.

Updated

8 years ago
Duplicate of this bug: 379663

Comment 18

7 years ago
This may be fixed in bug 389139. May even be a dupe.
Depends on: 389139

Comment 19

7 years ago
I'm now using 10.0+build1-0ubuntu0.11.04.1~mts1. Following the steps in the Description, no crash happened. However, after restarting, the account disappeared from the folder tree. The account was still available in Account Settings and, in Advanced Account Settings, the selected option had automatically gone back to "Inbox for this server's account". So, all I had to do was click OK, OK, restart, and the account was back in the folder tree. It seems contradictory to include the account itself in a drop-down list named "Inbox for /different/ account". Would it not be best to simply exclude it from the list?

Comment 20

7 years ago
The UI part should be fixed in bug 389139.
No longer depends on: 389139
Depends on: 389139
a couple people have tried and failed to reproduce instability, so calling this WFM
Assignee: mozilla → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

3 years ago
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.