Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 357334 - Quick editing of new event requires three clicks
: Quick editing of new event requires three clicks
Status: RESOLVED DUPLICATE of bug 343793
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2006-10-19 16:28 PDT by David Tenser [:djst]
Modified: 2006-10-19 23:02 PDT (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description David Tenser [:djst] 2006-10-19 16:28:56 PDT
To quickly create a new event, you just click and drag the length of the event in e.g. the day or week view. However, in order to actually change the event title from "New Event" to something meaningful, you then need to click the event again to select it, then click a third time over the actual text to make it an editable text box.

It would be much more intuitive if you would be able to start typing directly after clicking and marking the event the first time. Google Calendar does this very nicely: you click and drag, a friendly looking "balloon" appears where you can type the event title and select calendar, and optionally click a link to select more advanced details.

Steps to reproduce:

1. Click and drag in the day view to create a new event.
2. Click the newly event to select it.
3. Click on the "New Event" text.

The editable text box that appears after step 3 should have appeared already after step 1. Ideally, though, it should provide a little more information, as Google Calendar does.
Comment 1 David Tenser [:djst] 2006-10-19 16:31:33 PDT
The Google Calendar balloon that asks for the event title and calendar is also more convenient than the Edit Event because it's not a modal dialog -- you can just click outside of the balloon and it will disappear. No need to aim at the Cancel button if you just created the event by mistake.
Comment 2 Matthew (lilmatt) Willis 2006-10-19 23:02:48 PDT

*** This bug has been marked as a duplicate of 343793 ***

Note You need to log in before you can comment on or make changes to this bug.