The menu item View > Page Style > Basic Page Style is missing from the menu on some webpages

RESOLVED WORKSFORME

Status

()

Firefox
Menus
--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Jason Spiro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

At certain webpages such as www.cnet.com, www.download.com, or http://news.com.com:
- you can choose View > Page Style > No Style which causes Firefox to ignore all CSS
- but you cannot undo your choice by the standard method of View > Page Style > Basic Page Style.

Reproducible: Always

Steps to Reproduce:
1. Visit www.cnet.com, www.download.com, or http://news.com.com (note: all three pages are run by CNet)
2. Choose View > Page Style > No Style
3. Oops! I didn't want No Style since the page looks so ugly with CSS disabled.
4. Try to go back to Basic Page Style

Actual Results:  
There is no View > Page Style > No Style menu option so now you are stuck on the ugly No Style option.

Expected Results:  
You should be able to choose View > Page Style > No Style.

Workaround: Go to a webpage that is unaffected by the bug such as www.google.com, then choose Basic Page Style, then click the Forward button.

If you would like me to retest on a nightly, please email me.
(Reporter)

Updated

11 years ago
Summary: Cannot choose View > Page Style > Basic Page Style on some pages → The menu item View > Page Style > Basic Page Style is missing from the menu on some webpages
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061019 Minefield/3.0a1

I see the problem indeed in Firefox 1.5.0.7, but it is fixed in the latest nightlies. You can try it out:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.