Last Comment Bug 357340 - Ability to select which calendar events show up in event list
: Ability to select which calendar events show up in event list
Status: RESOLVED DUPLICATE of bug 350439
:
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Trunk
: x86 All
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 17:03 PDT by David Tenser [:djst]
Modified: 2009-08-30 00:43 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description David Tenser [:djst] 2006-10-19 17:03:59 PDT
The event list shown above the calendar has a view filter allowing to list e.g. "All Events" or "Events in the Next 7 Days". However, it's not possible to select which calendars to include. 

Use case: David (yep, that's me) has one Work calendar and one Personal calendar. He also has an Ubuntu Development Schedule calendar subscription, but he would rather not clutter his event list with the Development Freeze deadline for Ubuntu.
Comment 1 Matthew (lilmatt) Willis 2006-10-19 23:05:34 PDT
(In reply to comment #0)
> Use case: David (yep, that's me) has one Work calendar and one Personal
> calendar. He also has an Ubuntu Development Schedule calendar subscription, but
> he would rather not clutter his event list with the Development Freeze deadline
> for Ubuntu.

...and you want to still see the Ubuntu calendar in the grid below, just not in the search results?

Comment 2 David Tenser [:djst] 2006-10-20 02:49:00 PDT
Yes. I view the "search list" (I'd rather call it the agenda, because I don't have to search for things in order for items to appear in it) to only contain events relevant to me personally. However, I'd like the actual calendar to be filled with everything in the checked calendars.
Comment 3 Damian Szczepanik 2006-10-31 13:08:07 PST
I see some solutions:

1. resolved as duplicate of bug 350439 but support this agenda
2. make events in unifinder colorful so you can easly sort by category and calendar
3. resove as wontfix because user can uncheck all (except one) calendars in calendar panel what is very not user friendly
Comment 4 Philipp Kewisch [:Fallen] 2009-08-30 00:43:32 PDT
At least in Lightning, the unifinder is scheduled to go away in favor of making use of the (gloda) search. I think the actual agenda should be looked at in the today pane.

If we provide yet another place where the user can set which calendars should be shown, this will become even more confusing. We were already contemplating the same for the today pane, the task list, etc.

I think there are enough workarounds (i.e checking the calendar list), so I'm marking this bug duplicate.

*** This bug has been marked as a duplicate of bug 350439 ***

Note You need to log in before you can comment on or make changes to this bug.