Exported CSV files doesn't have an header

RESOLVED DUPLICATE of bug 180057

Status

RESOLVED DUPLICATE of bug 180057
12 years ago
12 years ago

People

(Reporter: eg, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/1.5.0.5 Flock/0.7.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/1.5.0.5 Flock/0.7.4.1

The exported CSV files from the address book doesn't contain a header, this makes it incompatible with for instance gmail importing. The header that needs to be prepended as an own line is: first name,last name,display name,nickname,email address,alt email address, work phone,home phone,fax,pager,mobile,address1,address2,city,state,zip,country,work address1,work address2,work city,work state, work zip,,,,organization,,,,,,,,,,notes


Reproducible: Always

Steps to Reproduce:
1. Export a csv file in the address book.

Actual Results:  
A cvs file without header is produced

Expected Results:  
A cvs file with the header: first name,last name,display name,nickname,email address,alt email address, work phone,home phone,fax,pager,mobile,address1,address2,city,state,zip,country,work address1,work address2,work city,work state, work zip,,,,organization,,,,,,,,,,notes

then the addresses.

I found my solution here:
http://www.jurriaanpersyn.com/archives/2006/04/04/import-thunderbird-contacts-in-gmail/
Duplicate of bug 180057 - it has already been implemented for the upcoming Thunderbird 2.0/SeaMonkey 1.1 releases.

*** This bug has been marked as a duplicate of 180057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.