If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Email with attachements: 'Save as...' doesn't work right

RESOLVED DUPLICATE of bug 354954

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 354954
11 years ago
11 years ago

People

(Reporter: Richard Brackin, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061020 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20061020 SeaMonkey/1.5a

It appears when there is one attachment in an email message, selecting it, and control+clicking (mac) brings up a dialogue to save as... but nothing happens when I select it.  I have to 'save all' to actually save the attachment to another location on my computer.

October 20 2006 trunk release

When multiple attachments are in an email message, I must select all the attachments. Then, if I contol+click (mac) save as... the dialogue box pops up but only chooses to save the bottom attachment. The others are ignored.

Save as... doesn't work at all unless there are multiple attachments, and they are all selected. But even then it only saves the last attachment. At that point, one may as well 'save all' instead.

Reproducible: Always

Steps to Reproduce:
1. Receive two emails -- one with one attachment, and one with two or attachments
2. On mac, put your mouse over the attachment and control+click the the email with one attachment and click 'save as...'
3. On mac, put your mouse over one of the attachements and control+click the email with several attachments and click 'save as...'


Actual Results:  
You should find that clicking save as... does nothing when trying to save a single attachment. It doesn't matter whether it's selected or not. You'll also probably find that selecting all the attachments in the multiple attachment email , then contol+clicking to save as... will save only the last attachment in the list.

Expected Results:  
Pointing the mouse onto an attachment, control+clicking to save as... should do just that. It should bring up a dialogue box asking where to save that specific attachment.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 1

11 years ago
I think we might have two issues here:

1) Save As doesn't work
2) Saving multiple attachments only save one (the last)

1) is most likely a regression from bug 326469 and a dupe of bug 354954

The other issue could be separate, not sure. Can you try with a build from September 28 and see if both issues are absent (bug 326469 was fixed the 29:th)?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
Sorry for the delay in getting back with you.

The September 28 release works correctly. I downloaded seamonkey-1.0.5.en-US.mac.dmg from Sep 28, 2006 and it showed the last modified time as being 22:50

Both issues are absent in the Sep 28, 2006 release at 22:50
(Reporter)

Comment 3

11 years ago
Correction: I accidentally wasn't using the trunk build on my last comment.
Indeed, the Sept 28 trunk works correctly.
The Sept 29 trunk broke the functionality and introduced the bugs I mention here.

Comment 4

11 years ago
(In reply to comment #3)
> Correction: I accidentally wasn't using the trunk build on my last comment.
> Indeed, the Sept 28 trunk works correctly.
> The Sept 29 trunk broke the functionality and introduced the bugs I mention
> here.
> 

OK, thanks :-)

I'm gonna dupe this bug against bug 354954. If you still see issue 2) after that one is fixed it's probably a separate bug - feel free to file a new one then.

*** This bug has been marked as a duplicate of 354954 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.