Last Comment Bug 357457 - [reflow branch] <select> with CSS width:0 height:0 is visible
: [reflow branch] <select> with CSS width:0 height:0 is visible
Status: RESOLVED WONTFIX
[questionably valid]
: css3, regression, testcase
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Other Branch
: x86 Linux
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 243412
Blocks: reflow-refactor
  Show dependency treegraph
 
Reported: 2006-10-20 18:14 PDT by Mats Palmgren (:mats)
Modified: 2009-03-31 08:28 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase #1 (655 bytes, text/html)
2006-10-20 18:16 PDT, Mats Palmgren (:mats)
no flags Details

Description Mats Palmgren (:mats) 2006-10-20 18:14:57 PDT
[reflow branch] <select> with CSS width:0 height:0 is visible

This is bug 58220 that has come back.
Given the styles, I think the rendering is correct per CSS 2.1, but since 58220
was an accepted bug I wanted to make you aware of the diff to trunk...
(Apologies for the spam if you're aware of it)
Comment 1 Mats Palmgren (:mats) 2006-10-20 18:16:46 PDT
Created attachment 242945 [details]
Testcase #1

Trunk: two green boxes
Reflow-branch: two red boxes
Comment 2 Boris Zbarsky [:bz] 2006-10-20 20:28:20 PDT
Yeah, I did see bug 58220 in the log when I was working on this code and I did test against those testcases (as well as all other existing form control regression tests).  Since I wasn't running into the _real_ issue that bug was reported on (that of the scrollbars just doing very wacky things, etc).  Given that the only reason for width:0; height:0 was bug 34297, I decided this was an acceptable behavior change in return for much cleaner code.

So I'm somewhat tempted to wontfix this, to be truthful.
Comment 3 Mats Palmgren (:mats) 2006-11-08 05:06:19 PST
Gecko reflow-branch and IE7: green boxes
Gecko trunk, Opera9 and Webkit (2006-11-08): red boxes

Could we keep the bug open until 'box-sizing:border-box' is more clearly
specified, so we don't forget about the issue?
http://www.w3.org/TR/2002/WD-css3-box-20021024/#the-box-width
Comment 4 Boris Zbarsky [:bz] 2006-11-08 07:26:52 PST
I suppose...  we should mark it dependent on whatever bug is tracking box-sizing, then.
Comment 5 Bill Gianopoulos [:WG9s] 2006-11-10 08:55:17 PST
The behavior on the reflow branch matches the Opera behavior.  The trunk and Firefox 2.0 behavior matches what IE7 does.
Comment 6 Mats Palmgren (:mats) 2006-11-10 10:40:19 PST
Right, "reflow-branch"/"trunk" should be swapped in my comment 3.
Comment 7 Daniel.S 2009-02-07 08:27:01 PST
IE8rc1 and Opera's latest weekly also render two red boxes. So everyone agrees on this case, maybe it can be wontfixed now?
Comment 8 Boris Zbarsky [:bz] 2009-03-31 08:28:58 PDT
Yeah, I think so.

Note You need to log in before you can comment on or make changes to this bug.