Cannot make "home" toolbar button load a blank page

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
12 years ago
a year ago

People

(Reporter: nrlz, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I tried to set a blank page as my homepage in Firefox 2.0 by clearing the homepage text box in the options dialog. Pressing the "Home" button in the Firefox toolbar still loads the Google search engine, even though my homepage is set to the blank page.

Reproducible: Always

Comment 1

12 years ago
You actually can do this, it's just sort of hidden. Choose the "Show a blank page"  option from the "When Firefox starts:" dropdown in the Main tab. ->WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → Preferences
QA Contact: general → preferences
Resolution: --- → WORKSFORME
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> You actually can do this, it's just sort of hidden. Choose the "Show a blank
> page"  option from the "When Firefox starts:" dropdown in the Main tab.
> ->WORKSFORME
> 

That only changes what is loaded when Firefox first starts up, and not what happens when I press the Home toolbar button. i.e., When Firefox starts up, it loads a blank page. That is correct so far. But when I press the Home toolbar button, the Google search page appears, even though I cleared the homepage text box.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

12 years ago
OK. I see what you mean now. There is a way to do this; just type "about:blank" into the Home Page field. Unfortunately, not many people know about about:blank.

I think bug 346044's original intent was to solve this problem, but it got morphed into something else.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
The official solution is to open a new window containing only one blank tab and then tell Firefox to use the current (blank) page as homepage (Tools -> Options -> Use Current Page). -> WORKSFORME

An empty homepage (i.e. no "about:blank") won't work until bug 342340 is fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 401912
Created attachment 8793498 [details] [diff] [review]
Don't allow content scripts on pages with mozAddonManager

MozReview-Commit-ID: 8dzouTOzKcN

Updated

a year ago
Assignee: nobody → aswan

Updated

a year ago
Attachment #8793498 - Attachment is obsolete: true

Updated

a year ago
Assignee: aswan → nobody
You need to log in before you can comment on or make changes to this bug.