live bookmarks fail to load after switching proxy settings

RESOLVED INCOMPLETE

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: matt, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I have some live bookmarks in my toolbar.  I am connected to work (manual proxy config enabled), and later I disconnect from work (VPN) and close firefox.  When I restart Firefox, it looks for the proxy but doesn't find it, therefore causing all live bookmarks to fail to load.  Even if I immediately chang my proxy setting back to "Direct connection", my live bookmarks do not load.

This might be espected behavior, but the text in my live bookmarks says "live bookmark loading" which is not accurate.  Either the LBs dont see that I switched proxy, or they have failed to load and the text should say so.  

Ideally, they would see the proxy switch and then load.  My only work around to this point is start browser, switch proxy, close browser, start browser.  I am going to try some extensions, but I think that firefox itself should look into this one.

Thanks!

Reproducible: Always

Steps to Reproduce:
1. have incorrect proxy settings
2. start firefox
3. look at live bookmarks
4. set proxy settings to correct values
5. while (1)
  5a. wait for live bookmarks to "load"

Comment 1

12 years ago
As I understand it, Live Bookmarks are refreshed on startup and then in 30 minute intervals thereafter. So if you change your connection settings after you start you won't see them refresh for another ~30 minutes.

That brings up the question of if Live Bookmarks should refresh when your connection settings change. It seems that that issue is a WONTFIX per bug 278250.
(Reporter)

Comment 2

12 years ago
I didn't about know the 30 minute "timer".  Should the text of the LBs change to "cannot load LB, will try again in 30 minutes?"  The text currently is somewhat misleading.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
Closing as incomplete -> no feedback

Reporter: if you still see this Problem with a recent Firefox Release or Firefox 3 Beta 5, feel free to reopen. Also please see comment #1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.