If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

alt + s to get focus in navigation is wrong > STRG + L works fine already

RESOLVED DUPLICATE of bug 349716

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 349716
11 years ago
11 years ago

People

(Reporter: Georg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0

In RC3 you get the foucs with ALT+S and STRG + T. First is wrong because 2nd exists already and ALT+S is an often used access+key, e.g. for sending forms or for some menu items! 

Reproducible: Always

Steps to Reproduce:
1. visit a page which has gotten an access key (accesskey="s")
2. press alt+s
3. you get focus instead of the link/sending form/...
Actual Results:  
focus @ url

Expected Results:  
performing the access-key

Comment 1

11 years ago
Should we use ALT + Shift + accessKey for Fx2RC3? Alt + D is used to focus on url bar. Alt + S is menu Hi(s)tory on my box.
(Reporter)

Comment 2

11 years ago
Strange... i noticed that none of the accesskeys work now with alt + key anymore. I don't like the alt+shift+key because it's another key more...

Do it like this way:
all accesskeys: ALT + key
all shortcuts for firefox itself or getting focus: STRG + key > like history (strg+h), changing tabs (strg + tab), focus @ url (Strg+t), search focus (strg+e),  closing tab (strg +w), new tab (strg+t) ...

you see.. there is no reason to make a focus with ALT for me

Comment 3

11 years ago
I don't know how to active the accesskey with fx2 at first. But less keys seem more accessible.
(Reporter)

Comment 4

11 years ago
> I don't know how to active the accesskey with fx2 at first. But less keys seem
> more accessible.

you don't have to activate them... would be new to me.. 

Comment 5

11 years ago
(In reply to comment #2)
Please don't confuse access keys and shortcut keys. Access keys are for accessing visible elements (e.g. menus and address bar) whereas shortcut keys are for invoking functionality.

See bug 128452 for why using Alt for both browser and website accesskeys was a bad idea.

*** This bug has been marked as a duplicate of 349716 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.