Master password prompt twice/none when starting Firefox 2

RESOLVED DUPLICATE of bug 267807

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 267807
12 years ago
10 years ago

People

(Reporter: wayneisaacs, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Get the master password prompt twice when starting Firefox 2. This problem only started after upgrading from Firefox 1.5.0.7 to Firefox 2 RC 3.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox 2
2.
3.

Comment 1

12 years ago
Are you using a proxy?
Summary: Get the master password prompt twice when starting Firefox 2. → Get the master password prompt twice when starting Firefox 2
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

12 years ago
No I am not using a proxy

Comment 3

12 years ago
WFM "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061020 BonEcho/2.0"

Comment 4

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1) Gecko/20061010
BonEcho/2.0
WFM

Comment 5

11 years ago
Hi

Same problem here with 2.0.0.2 in linux/win, but only from time to time. For versions 1.5x (win/linux) the password was asked even 3 or 4 times.


regards

I can confirm this behavior on Mac OS X. Since a couple of days I see the master password dialog twice sometimes. It also appears that it is never shown at start-up when a password site from the last session is already open. Dunno if this should be a separat issue.

Reporter, do you have installed other locales? My impression is that it is happen when switching between them. Especially for me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 367491

Comment 8

11 years ago
I've checked on the latest release from Firefox 2.0.0.3 and this error only appears on linux not on windows.
Today 3 popup windows for entering the Master Password where opened. I just enter the password in one of them and press cancel on the others.


regards

---
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070320 SUSE/2.0.0.3-11.2 Firefox/2.0.0.3
Has anyone of you installed the Gmail Notifier 0.5.6.5? For me this extension causes this issue. If you have opened a site within your last session which is protected or a login is needed Firefox shows the master password dialog twice on the next start. I can reproduce this issue on every start of Firefox.
This only happens if you set "Automatically log in" to true. In that case the extension wants to log in at startup. If you already have opened another site with an authentication request both requests for the master password seems to run in "parallel". I don't know any another extension which makes use of that feature. So I cannot test if that's an extension or core issue.

Benjamin, do you have an idea what going on?

Comment 11

11 years ago
Hi Henrik
I'm also using the same version of Gmail Notifier and you are right. Disabling it makes the dialog visible only once.

regards
I retried on OS X and on that OS no master password dialog will be opened. That's a different behavior as on Windows. You are not able to work with Thunderbird anymore until you disable the gmail notifier or remove the automatically login.

Marcia, could you try to reproduce it plz?
Here is the behavior I see on Mac with the Gmail Notifier Installed. I am using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4pre) Gecko/2007051603 BonEcho/2.0.0.4pre.

1. With auto login disabled, if I click on the Gmail notifier in the status bar I get prompted with 1 Master Password dialog. Note that it takes a long time for the Master Password dialog to come up.
2. With auto login enabled, if I restart Firefox I am prompted once for a Master Password.
(In reply to comment #13)
> 2. With auto login enabled, if I restart Firefox I am prompted once for a
> Master Password.

Also if you restore your last session with opened pages which requires authentication's?
After an extension install, when Firefox restarts I get one prompt for the Master Password as well. This time I am testing Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4, which is our release candidate.
Summary: Get the master password prompt twice when starting Firefox 2 → Master password prompt twice/none when starting Firefox 2
After upgrading my branch nightly build to Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070521 BonEcho/2.0.0.4pre I got the message that GMail notifier 0.6 is available. I installed that update. Now the master password dialog is also prompted twice when I've disabled auto-login. I have to disable that extension to circumvent this issue.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381164
Duplicate of bug: 267807
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.