No keyboard shortcut in Composer for selecting CC or BCC recipient type

RESOLVED DUPLICATE of bug 301465

Status

--
minor
RESOLVED DUPLICATE of bug 301465
12 years ago
12 years ago

People

(Reporter: luca.azzalini, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

You are forced to use the mouse if you want to change the recipient type from To to CC or BCC.
Yes, you can use the keyboard, but it's horrible. You can use Shift+Tab to move from the address field to the recipient type selection dropdown, but it doesn't looks like it has the keyboard focus: no cursor, no dotted rectangle, no inverse painting. Nothing.


Reproducible: Always

Steps to Reproduce:
1. Start compose a new message
2. enter an address
3. Hit enter (move to 2nd line)
4. press Shift-Tab


Actual Results:  
Where is the keyboard focus?

Expected Results:  
No visual indication of where is the keyboard focus

show the "To:" label in "selected style"
(Reporter)

Comment 1

12 years ago
It would be much more usable if the recipient type dropdown were a field in wich tab whould stop

Comment 2

12 years ago
(In reply to comment #0)
> You can use Shift+Tab to move from the address field to the recipient type
> selection dropdown, but it doesn't looks like it has the keyboard focus: no
> cursor, no dotted rectangle, no inverse painting. Nothing.

Very true.  Is that what this bug is about?  Then it's a dupe of bug 301465.

You can customize this yourself; in the 'chrome' directory of your profile, edit (or create)  userChrome.css   and add these lines:
========================
/* [from bug 285288 / 301465]
 * show addressing widget in the mail editor as button 
 * (overriding native theming)
 */
.menulist-compact {
   -moz-appearance: button !important;
}
 
.menulist-compact > .menulist-dropmarker {
   -moz-appearance: none !important;
}

.menulist-compact:focus > .menulist-label 
{
  -moz-outline: 1px dotted invert !important;
  color: -moz-activehyperlinktext !important;
}  
========================

The Pinstripe theme has this built in already, I think.
(Reporter)

Comment 3

12 years ago
Yes, OK, thanks a lot! It works!

What about making the dropdown a stop when tabbing through the fields (To/CC/BCC and the addresses) ?

regards

Comment 4

12 years ago
(In reply to comment #3)
> Yes, OK, thanks a lot! It works!

OK, if that's what you wanted, I'll dupe this.


> What about making the dropdown a stop when tabbing through the fields
> (To/CC/BCC and the addresses) ?

I don't understand -- those dropdowns act as tab stops for me.  If you tab from the last address field, focus jumps to Subject -- this is desirable.  If you want to create a new address field after entering one, hit <return>, then Shift+Tab to change the field type if necessary.  <return> will copy the field type, so if you change one to a CC, the subsequent one will also be CC.

*** This bug has been marked as a duplicate of 301465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.