Last Comment Bug 357687 - Jewish Calendar, in Hebrew and English (contribution for Lightning)
: Jewish Calendar, in Hebrew and English (contribution for Lightning)
Status: RESOLVED INCOMPLETE
:
Product: Calendar
Classification: Client Software
Component: Website (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Tomer Cohen :tomer
:
Mentors:
: 379434 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-23 09:59 PDT by Zvi Har'El
Modified: 2012-01-02 07:55 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
http://www.math.technion.ac.il/~rl/luach/5767.he.ics (54.51 KB, text/calendar)
2006-10-23 10:07 PDT, Zvi Har'El
no flags Details
http://www.math.technion.ac.il/~rl/luach/5767.en.ics (50.53 KB, text/calendar)
2006-10-23 10:09 PDT, Zvi Har'El
no flags Details
Screenshot for 5767.he.ics imported into Thunderbird with Lightnining (112.97 KB, image/jpeg)
2006-10-23 10:23 PDT, Zvi Har'El
no flags Details
Screenshot for 5767.en.ics imported into Thunderbird w/Lightning (146.48 KB, image/jpeg)
2006-11-04 07:16 PST, Zvi Har'El
no flags Details
Holidays only, English, Diaspora Style (6.70 KB, text/calendar)
2006-11-04 07:44 PST, Zvi Har'El
no flags Details
Holidays only, Hebrew, Israel Style (6.64 KB, text/calendar)
2006-11-04 07:46 PST, Zvi Har'El
no flags Details
Jewish Holidays, English, Diaspora Style 9/2006-9/2008 (9.45 KB, text/calendar)
2007-06-28 00:17 PDT, Zvi Har'El
no flags Details
Jewish Holidays, Hebrew, Isreal Style 9/2006-9/2008 (9.51 KB, text/calendar)
2007-06-28 00:19 PDT, Zvi Har'El
no flags Details
obsolete (9.45 KB, text/calendar)
2007-09-23 11:24 PDT, Zvi Har'El
no flags Details
obsolete (9.71 KB, text/calendar)
2007-09-23 11:25 PDT, Zvi Har'El
no flags Details
obsolete (9.55 KB, text/calendar)
2007-09-23 11:31 PDT, Zvi Har'El
no flags Details
obsolete (9.63 KB, text/calendar)
2007-09-23 11:32 PDT, Zvi Har'El
no flags Details
Jewish Holidays, Hebrew, Isreal Style 9/2007-9/2009 (9.43 KB, text/calendar)
2007-09-23 11:36 PDT, Zvi Har'El
no flags Details
Jewish Holidays, English, Diaspora Style 9/2007-9/2009 (9.39 KB, text/calendar)
2007-09-23 11:38 PDT, Zvi Har'El
no flags Details

Description Zvi Har'El 2006-10-23 09:59:36 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Attached, a Jewish calendar in Hebrew, for use in Isreal, and English, for use elsewhere. The diffrence is (in addition to the language, of course), also in the Holidays (where extra days are added in the Diaspora), and the Pentatuch portion read in Saturdays. The Calendar is valid for the current Jewish year, 5767 A.D., 23 September 2006 - 12 September 2007 C.E., but similar iCalendar files for an arbitrary year can be downloaded from my homepage, http://www.math.technion.ac.il/~rl/ .

The exact URL for the year <YYYY> A.D. (which starts around September <YYYY>-3761 and ends around September <YYYY>-3760) and the language <LL> (he or en) is

http://www.math.technion.ac.il/~rl/luach/<YYYYY>.<LL>.ics

You can also download the C program luach-ical which produce these files from my homepage.

Reproducible: Always
Comment 1 Zvi Har'El 2006-10-23 10:07:23 PDT
Created attachment 243210 [details]
 http://www.math.technion.ac.il/~rl/luach/5767.he.ics

Jewish Calendar for the year 5767 A.D., 2006-2007 C.E., in Hebrew, including Holidays and Pentatuch reading portions for Israel.
Comment 2 Zvi Har'El 2006-10-23 10:09:52 PDT
Created attachment 243211 [details]
 http://www.math.technion.ac.il/~rl/luach/5767.en.ics

Jewish Calendar for the year 5767 A.D., 2006-2007 C.E., in Hebrew, including Holidays and Pentatuch reading portions outside Israel (in the Diaspora).
Comment 3 Zvi Har'El 2006-10-23 10:23:37 PDT
Created attachment 243218 [details]
Screenshot for 5767.he.ics imported into Thunderbird with Lightnining
Comment 4 Simon Paquet [:sipaq] 2006-11-04 02:35:51 PST
Hi Zvi Har'El,
our (limited) aim for the website is to just provide basic holiday calendars. A complete calendar is not what we aim for and would consider such a calendar to be quite unusable in our current Gregorian-oriented interface.

Therefore I won't add these calendars to the website, but I'll gladly take a Jewish holiday calendar, if you want to provide one.
Comment 5 Zvi Har'El 2006-11-04 04:53:42 PST
I think that the current Gregorian-oriented interface is quite adequate, and you shoud consider my calendars as holyday calendards, the only specialty is every day is a holiday. You can compare this with the Catholic holiday calendar, where every day is named after a diffrent saint.
Comment 6 Simon Paquet [:sipaq] 2006-11-04 06:21:07 PST
Like I said, our (limited) aim for the website is to just provide basic holiday calendars. A catholic holiday calendar with the names of all the saints for every day will also be denied, should it be requested.
Comment 7 Zvi Har'El 2006-11-04 07:16:41 PST
Created attachment 244678 [details]
Screenshot for 5767.en.ics imported into Thunderbird w/Lightning

See how it looks in English
Comment 8 Zvi Har'El 2006-11-04 07:42:28 PST
I am attaching two new files, which are an extrract from the above, and include just the holidays for 2006-7.
Comment 9 Zvi Har'El 2006-11-04 07:44:38 PST
Created attachment 244680 [details]
Holidays only, English, Diaspora Style
Comment 10 Zvi Har'El 2006-11-04 07:46:00 PST
Created attachment 244681 [details]
Holidays only, Hebrew, Israel Style
Comment 11 Sebastian Schwieger 2006-11-05 17:01:47 PST
Reopen, because now we have Holidays, only.
Comment 12 Simon Paquet [:sipaq] 2006-11-06 04:01:27 PST
Calendar files checked in. Thanks for your contribution.
Comment 13 Simon Paquet [:sipaq] 2007-05-05 16:09:41 PDT
*** Bug 379434 has been marked as a duplicate of this bug. ***
Comment 14 Zvi Har'El 2007-06-28 00:14:51 PDT
Reopen. The current files ends on Septermber 12. I attach new files, each covers two Jewish years, from September 23, 2006 until September 29, 2008.
Comment 15 Zvi Har'El 2007-06-28 00:17:39 PDT
Created attachment 270143 [details]
Jewish Holidays, English, Diaspora Style 9/2006-9/2008
Comment 16 Zvi Har'El 2007-06-28 00:19:09 PDT
Created attachment 270144 [details]
Jewish Holidays, Hebrew, Isreal Style 9/2006-9/2008
Comment 17 Simon Paquet [:sipaq] 2007-06-30 08:38:12 PDT
Updated files checked in. Thanks.
Comment 18 Zvi Har'El 2007-09-23 11:24:05 PDT
Created attachment 282024 [details]
obsolete
Comment 19 Zvi Har'El 2007-09-23 11:25:22 PDT
Created attachment 282025 [details]
obsolete
Comment 20 Zvi Har'El 2007-09-23 11:31:38 PDT
Created attachment 282026 [details]
obsolete

(282024 was a wrong calendar)
Comment 21 Zvi Har'El 2007-09-23 11:32:55 PDT
Created attachment 282027 [details]
obsolete

(282026 was a wrong calendar)
Comment 22 Zvi Har'El 2007-09-23 11:36:47 PDT
Created attachment 282028 [details]
Jewish Holidays, Hebrew, Isreal Style 9/2007-9/2009
Comment 23 Zvi Har'El 2007-09-23 11:38:06 PDT
Created attachment 282029 [details]
Jewish Holidays, English, Diaspora Style 9/2007-9/2009
Comment 24 Zvi Har'El 2007-09-23 11:47:07 PDT
Reopen. We just celebrated the Jewish new Year: Attachments 282028 and 28209 are new calendar files, each covers two Jewish years, from September 13, 2007 until September 18, 2009 (Sorry for the noise by adding few bad attachments earlier today. I made them obsolete - I wish I could simply delete them :-( ).
Comment 25 Simon Paquet [:sipaq] 2007-10-21 05:11:24 PDT
Updated calendar files checked in. Thanks for your contribution.
Comment 26 Simon Paquet [:sipaq] 2010-01-09 03:57:29 PST
Zvi, I've removed the Jewish holidays from our website for now, as the files are outdated (they only contain holidays until 2009). Can you please attach an updated file covering 2010 and 2011 (if possible) here?
Comment 27 Simon Paquet [:sipaq] 2010-08-18 08:49:39 PDT
No response from reporter. Resolving as INCOMPLETE to get it off the bug lists.
Comment 28 Tomer Cohen :tomer 2010-08-18 09:06:36 PDT
Reopenng and assigning to myself. I will try to the command line required to regenerate this calendar.
Comment 29 [retired] 2010-10-19 06:18:52 PDT
(In reply to comment #28)
> Reopenng and assigning to myself. I will try to the command line required to
> regenerate this calendar.

Tomer: What's the current status on this?
Comment 30 Martin Schröder [:mschroeder] 2011-12-31 03:29:56 PST
This bug had no action for over a year. Therefore, resolving as INCOMPLETE, but feel free to file a new one if new calendar files have been generated.
Comment 31 nyh 2012-01-02 07:45:36 PST
Hi, I'm Zvi's son. Unfortunately he hasn't responded to the request for new calendar files because he died a couple of months after sending his previous attachments. I just noticed that you guys have been looking for a reply from him for 3 years...

Is there still a need for this? Is anyone still using this (I don't know - I don't know what "Lightning" is)?

If there is, I can try and generate this myself - I have all his software (and he published it as Free Software anyway), and know quite a bit about Jewish calendars and programming myself, so I can try to do this conversion myself.
Comment 32 Jan Bambach [:Jan] 2012-01-02 07:55:40 PST
Hello Nyh,

First of all, I want to offer you my condolences. I'm deeply sorry and saddened by the death of your father. This must be very difficult for you. You' are in my thoughts now since I know what it feels like to lose a loved person. He was really kind and his contributions pushed the Mozilla project forward. May god bless you and your family during this time and always.

I also want to wish you a wonderful New Year filled with abundance, joy, and treasured moments. May 2012 be your best year yet.

It would be really nice if you could try to create the calendar. Please make sure to attach it to this bug after you completed it and I will check it in as soon as possible.


Yours Sincerely,

Jan

Note You need to log in before you can comment on or make changes to this bug.