Closed Bug 357776 Opened 13 years ago Closed 13 years ago

wyciwig urls are showing in the address bar

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3 alpha1

People

(Reporter: ian, Assigned: Gavin)

References

()

Details

(Keywords: regression, smoketest, testcase)

Attachments

(2 files)

STEPS TO REPRODUCE
Go to:
http://www.hixie.ch/tests/adhoc/dom/level0/document/open/002.html
...and look at the address bar.

EXPECTED RESULTS
It should say:
http://www.hixie.ch/tests/adhoc/dom/level0/document/open/002.html

ACTUAL RESULTS
It says:
wyciwyg://0/http://www.hixie.ch/tests/adhoc/dom/level0/document/open/002.html
...instead.
Attached patch patchSplinter Review
Oops, createFixupURI takes an nsIURI, not a string.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #243367 - Flags: review?(mconnor)
Severity: major → normal
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Firefox 3 alpha1
Version: unspecified → Trunk
Attachment #243367 - Flags: review?(mconnor) → review+
mozilla/browser/base/content/browser.js 	1.726
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Attached file testcase in text plain
This works in the test harness found in bug 357523
Flags: in-testsuite?
Depends on: 359895
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061205 Minefield/3.0a1
Status: RESOLVED → VERIFIED
Blocks: 420331
You need to log in before you can comment on or make changes to this bug.