bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Need option to place 'Close Tab' button on either the tabs *or* the end of the tab bar.

RESOLVED DUPLICATE of bug 344182

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 344182
12 years ago
5 years ago

People

(Reporter: Chris Forsyth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Before the current build, I was using Tab Mix Plus. I strongly prefer having a single 'Close current tab' button on the end of the tab bar, rather than having separate close buttons on each tab. In particular, when you get to a point where opening and closing tabs causes the tabs themselves to change widths, the close button then becomes a moving target. Best solution IMHO would be to make both button locations be options in the Tab section of Options, letting both locations be used as prefered.

Reproducible: Always

Updated

12 years ago
Whiteboard: DUPEME
Also mentioned here: Bug 324227.
Component: Tabbed Browser → Preferences
QA Contact: tabbed.browser → preferences

Comment 2

12 years ago
I add my vote to this request. 

The new tab bar UI (which has long plagued both mozilla and firefox when too many tabs open) is great. Except for dropping one excellent functionality. 

Original reporter described it quite well. 
Also confirming it on win98. 

Comment 3

12 years ago
Workaround:

set in about:config
browser.tabs.closeButtons = 3

possible values:
0 - only selected tab shows button (on tab)
1 - standard behavior
2 - no buttons shown
3 - button on far right 

Comment 4

12 years ago
I might add that if there are enough tabs for the left-right navigation arrows to appear, tabs do NOT display the close button, which happens if there are fewer tabs. So closing tabs requires 2 clicks. 

The workaround described is missing an option, that _all tabs_ show the close button. 

Also, the workaround described, set to value = 3, has some slight graphical inconsistency, as the dropdown arrow is not rounded on the right side here. The close button could also be placed at the left of that drop-down, to the right of the left-right tab navigation buttons. Would make sense. 

Comment 5

12 years ago
agreed. I think this option is currently more of a hack than anything else, and is good for those of us set in our ways!

Hopefully in the next version or 2 they will include it as a proper option (and in the gui)
That is what this feature request is all about I guess.

Comment 6

12 years ago
*** Bug 359010 has been marked as a duplicate of this bug. ***
Maybe a Dupe of 324227 ?
OS: Windows 2000 → All
Resolving this as Dupe of Bug 344182

Please see comment#3 on Bug 344182

*** This bug has been marked as a duplicate of 344182 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.