New Event dialog isn't showed when calendar is set to read-only (Day View)

RESOLVED DUPLICATE of bug 313640

Status

RESOLVED DUPLICATE of bug 313640
12 years ago
12 years ago

People

(Reporter: JasnaPaka, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061023 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061023 Minefield/3.0a1

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061023 Calendar/0.4a1

1) Set calendar to "Read only".
2) Go to Month View and try to add new event. New dialog is showed with red warning that calendar is read-only. That's correct.
3) Go to Day View and try to add new event. No via New Event button but try to select some hour by mouse in Day View.

Reproducible: Always

Actual Results:  
No New Event dialog is showed with exception in Error Console:

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Programy/Mozilla%20Sunbird/components/calCompositeCalendar.js :: anonymous :: line 351"  data: no]
Source File: file:///C:/Programy/Mozilla%20Sunbird/components/calCompositeCalendar.js
Line: 351

*** This bug has been marked as a duplicate of 313640 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.