File associations fail if already the default browser

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Doctor Nemesis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

When doing a clean install of Firefox 2 RC 2, the file extensions for files such as HTML lost association with any programme. It appears to be because Firefox 2 RC 2 was the previous browser, and so was already assumed to have those associations.


Reproducible: Didn't try

Steps to Reproduce:
1. Uninstall an existing setup of Firefox 2 RC 2
2. Delete the remaining programme directory and the directory from the Documents and Settings folder.
3. Install Firefox 2 RC 2.
4. The HTML file extension is now not associated with anything. HTML documents will not launch from the Explorer.
5. Make IE the default browser.
6. Make Firefox the default browser.
7. Firefox is now associated with the HTML file.
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0 if i delete my Firefox and it was the standard browser, i get on a HMTL Dialog a Dialog "open with ..." and can chose the application, like IE7 or SeaMonkey.

I think this is not a Firefox Bug, its a default Windows Feature
(Reporter)

Comment 2

12 years ago
I don't think I've made myself clear. The problem is when you re-install Firefox, in my case an identical build to the one that was removed, it does not associate itself with HTML files. It should do so, it is the default browser.

It did not ask me if I would like to make it the default browser, so I assume that it was already so. I had not made IE the default after un-installing, and IE did not appear to believe it was the default either. It's possible that I've chosen the wrong component to list this problem under, but I thought installer was the most appropriate. 

(In reply to comment #1)
> WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010
> Firefox/2.0 if i delete my Firefox and it was the standard browser, i get on a
> HMTL Dialog a Dialog "open with ..." and can chose the application, like IE7 or
> SeaMonkey.
> 
> I think this is not a Firefox Bug, its a default Windows Feature
> 

What is the specific symptom? Is it that html files don't show the Firefox icon or is it that clicking to open an html file does not open Firefox?
(Reporter)

Comment 4

12 years ago
If Firefox is the default browser, but is not installed, when the browser is re-installed it does not associate itself with the file types.

Thus, the icon for an HTML file is Windows unknown file type icon, and double clicking an HTML file causes a query for an application.
The only time it wouldn't open is if it was installed into a different directory and if it was installed into a different directory then you should be prompted to set that install as the default browser unless you changed the pref so it would not check. This is the way all browsers and other apps that can be default handlers work in that if they are uninstalled and installed into a new directory then the association will be lost until it is re-associated. One thing that may have caused this for you is that it did install into a different directory for the betas so installation of an RC would install into a different directory. What ever the case with the landing of bug 369048 this should be resolved now.

Can you reproduce with a release build?
(Reporter)

Comment 6

12 years ago
No. I've just briefly tried with 2.0.0.1 and that seems fine, although I did not delete the preference directories this time (previously it failed regardless).

However, there are no icons for the HTM and HTML file extensions. I'm not sure that there ever were...
I highly suspect the directory change that was done for the betas is what caused this for you. Resetting as the default browser should set the icon though there is another bug that could cause this.

Resolving -> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.