Frequent crashes when inadvertently double clicking the menu bar

RESOLVED DUPLICATE of bug 351230

Status

()

RESOLVED DUPLICATE of bug 351230
12 years ago
12 years ago

People

(Reporter: e14iron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

When double clicking (inadvertent) on the menu bar, Firefox 2.0 often crashes and does not always trigger talkback. Appears to be associated with when a page is loading: ie if a page is slow to load and/ or I change my mind and THEN accidently double click on the menu bar - typically the bookmark menu, I get the spinning pizza and a crash a few seconds later. Has happened about 5 times in 24 hours. May also be associated with having several apps open (but no obvious pattern).


Reproducible: Sometimes

Steps to Reproduce:
(This is a bit of a guess)
1.Go to load a slow loading page;
2.Go to bookmarks menu and "inadvertently" double click it before the page has loaded.
3.

Actual Results:  
Periodic crashes (but not 100% of the time)

Expected Results:  
Let me select the bookmark menu and choose another item.

I'm on a Mac mini PPC G4/1.42ghz with 512bm RAM running 10.3.9.
(Reporter)

Comment 1

12 years ago
Just had it happen again, exactly as I described earlier: navigating around TV.com, changed my mind and went to call up my bookmarks, accidently double clicked in the menubar (on the word "Bookmarks"). Pizza spun for around 3 seconds, then FF crashed without invoking Talkback, althought he Apple crash reporter did notice.

I think this may be pertinent  -  I can supply more crash log:

Thread 0 Crashed:
0   com.apple.HIToolbox       	0x9746cb80 _Z15FadeMenuWindowsP14MenuSelectData + 0x60
1   com.apple.HIToolbox       	0x97451f98 _Z31SelectItemAndRestoreAllMenuBitsR14MenuSelectData + 0x194
2   com.apple.HIToolbox       	0x9740c1f4 _Z15TrackMenuCommonR14MenuSelectDataPh + 0x2e0
3   com.apple.HIToolbox       	0x97451590 _Z14MenuSelectCore5PointdmPP13OpaqueMenuRefPt + 0xb0
4   com.apple.HIToolbox       	0x97477a50 MenuSelect + 0x60
5   com.apple.HIToolbox       	0x975072f4 _Z16HandleMouseEventP14OpaqueEventRef + 0x54
6   com.apple.HIToolbox       	0x974c0a78 _Z27StandardMenuBarEventHandlerP25OpaqueEventHandlerCallRefP14OpaqueEventRefPv + 0x38
7   com.apple.HIToolbox       	0x973c5e50 DispatchEventToHandlers + 0x150
8   com.apple.HIToolbox       	0x973c60c4 SendEventToEventTargetInternal + 0x174
9   com.apple.HIToolbox       	0x973d8530 SendEventToEventTarget + 0x28
10  com.apple.HIToolbox       	0x973dc604 _Z16HandleMouseEventP14OpaqueEventRef + 0x184
11  com.apple.HIToolbox       	0x973d6ad0 _Z29ToolboxEventDispatcherHandlerP25OpaqueEventHandlerCallRefP14OpaqueEventRefPv + 0x1e8
12  com.apple.HIToolbox       	0x973c5f0c DispatchEventToHandlers + 0x20c
13  com.apple.HIToolbox       	0x973c60c4 SendEventToEventTargetInternal + 0x174
14  com.apple.HIToolbox       	0x973d8530 SendEventToEventTarget + 0x28
15  com.apple.HIToolbox       	0x973dc44c ToolboxEventDispatcher + 0x5c
16  com.apple.HIToolbox       	0x973f977c HLTBEventDispatcher + 0x10
17  com.apple.HIToolbox       	0x973ef618 RunApplicationEventLoop + 0x98
18  org.mozilla.firefox       	0x00293cd0 _ZN10nsAppShell3RunEv + 0x40
19  org.mozilla.firefox       	0x00331150 _ZN12nsAppStartup3RunEv + 0x3c
20  org.mozilla.firefox       	0x000127ec XRE_main + 0x1210
21  org.mozilla.firefox       	0x0000d768 start + 0x1b0
22  org.mozilla.firefox       	0x0000d5e8 start + 0x30
(Reporter)

Comment 2

12 years ago
Now happened several times, invariably associated with accidently double clicking on the Bokkmark menu bar.
(Reporter)

Comment 3

12 years ago
Getting annoying now - crashing very frequently when I click (not necessarily double-click) on the bookmark menu bar item. Never throws talkback.
This looks like the same problem as bug 351230 which already has some traction.  Marking duplicate.

Thanks for the bug report.

*** This bug has been marked as a duplicate of 351230 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

12 years ago
Ah. Thanks. I guess this is nature's way of telling me to upgrade to Tiger...
You need to log in before you can comment on or make changes to this bug.