Mozilla opens my IE favourites every time I start up

VERIFIED INVALID

Status

P3
normal
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: sfraser_bugs, Assigned: mozilla)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Why do we read IE favourites every time we start up? This takes about a quarter 
second on startup:

Start reading in IE Favorites.html
Finished reading in IE Favorites.html  (255839 microseconds)

and I have no interest in my IE favourites; I've never even changed from from teh 
defaults.
(Assignee)

Comment 1

19 years ago

*** This bug has been marked as a duplicate of 29359 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

19 years ago
It's not obvious to me that this is a dup of a bug entitled "Search.dll is loaded 
on startup". Why do you have to read in IE favourites at all?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

19 years ago
Simon: Read the comments on bug # 29359.


*** This bug has been marked as a duplicate of 29359 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

19 years ago
I *did* read the comments in that bug. What I'm questioning here is the fact that 
we read IE favourites *at all*, not when or how. I see the following 
possibilities:

1. Read them in every time (as we do now)
2. Figure out if the user has touched them ever (i.e. they are different than 
they were when IE was installed), and only read them if changed
3. Just read them once, and import them into our bookmarks
4. Read them in based on a user preference
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

19 years ago
Simon: if you don't like bug # 29359, then I'm going to make this bug INVALID.

Either we read them in at startup every time (which we currently do because of 
29359), we read them in when they are first needed (after 29359 is fixed), or we 
only read them in if the user somehow specifically states they want IE Favorites 
(making this bug a dup of 22642).
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID
mass-verifying Invalid bugs which haven't changed since 2001-12-31.

use the search string "PinballWizard" if you want to filter out this msg.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.