d3view.com - SVG inline not being rendered (wrong MIME type)

RESOLVED INVALID

Status

Tech Evangelism
Desktop
RESOLVED INVALID
12 years ago
4 years ago

People

(Reporter: suri bala, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060409 SUSE/1.5.0.1-22 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060409 SUSE/1.5.0.1-22 Firefox/1.5.0.1

I am looking to get Firefox display the SVG when embedded inline in a XHTML document. THe link http://dev.d3view.com has a simple SVG circle embedded inline at the bottom (for testing purposes) which IE displays fine but Firefox does not.
I would really appreciate if someone can help.

Reproducible: Always

Steps to Reproduce:
1. Visit the link http://dev.d3view.com
2. Look for a inline SVG in the document that is not rendered in Firefox
3. Visit the same url using Internet explorer and you will see it.

Comment 1

12 years ago
http://dev.d3view.com/ is serving up text/html instead of application/xhtml+xml, so it's being treated as classic HTML instead of an XML document which allows mixed namespaces.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → SVG
Product: Firefox → Core
Resolution: --- → INVALID
Version: unspecified → Trunk
A valid evangelism bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: SVG → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
Summary: SVG inline is not being rendered. IE has no problem when viewing the url above. → d3view.com - SVG inline not being rendered (wrong MIME type)

Comment 3

4 years ago
We get redirected to a login page without any SVG.
http://dev.d3view.com/account/login

This seems to be invalid anymore
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 12 years ago4 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.