Spellchecker in Firefox does not honour lang= markup

RESOLVED DUPLICATE of bug 338427

Status

()

defect
RESOLVED DUPLICATE of bug 338427
13 years ago
13 years ago

People

(Reporter: masala.wallah, Assigned: mscott)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

The way how firefox selects the dictionary in order for spellchecking textareas is blind to the language markup. This affects multilingual users who have to select the correct dictionary language afresh for each new input box. Currently, Firefox just remembers one default language which reflects the last time the user choose a language for spellchecking from the context menu.

This is useless harass because HTML supports a mechanism to declare the language of a document, or a part thereof. Firefox uses this information for other purposes, e.g., CSS styling, so it is there, it gets parsed and IMHO it should be used for dictionary selection.

Reproducible: Always

Steps to Reproduce:
1. Open page indicated above
2. See red underlines that indicate "spelling mistakes"
3. Verify by context menu/properties that each textarea has its language declared.

Actual Results:  
Firefox indicates "spelling errors" that result from the use of the wrong dictionary.

Expected Results:  
Firefox should use the available language information in the HTML markup to decide which dictionary to use, or to not perform spell check at all.

*** This bug has been marked as a duplicate of 338427 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.