Closed Bug 358034 Opened 14 years ago Closed 14 years ago

Replace litmusconfig.js with alternate lookup methods

Categories

(Webtools Graveyard :: Litmus, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 358817

People

(Reporter: coop, Unassigned)

References

()

Details

We've talked about doing this before, so I want to get this on the radar. 

The static litmusconfig.js file contains a multi-dimensional array/object that contains information about products/branches/testgroups/subgroups. This file is used for quick lookups and for building many of the drop-down select lists. 

However, the format of the data structure was never updated as new database fields were created and relationships changed, so there are various workaround/hacks in the code now to create these various data relationships. Also, because the file is world-readable (and needs to be), it cannot contain any admin-only or private data, so all the admin functions must perform lookups by different means anyway.

We should create a set of reusable components (perl/template/js) for generating this information on the fly, and then replace everything that relies on litmusconfig.js with the new components.
QA Contact: ccooper → litmus
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 358817
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.