Closed Bug 358044 Opened 16 years ago Closed 16 years ago

No mouse wheel scrolling when over certain (background?) areas

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 258006

People

(Reporter: david.reitter, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061021 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061021 Camino/1.1a1+

Mouse wheel scrolling doesn't work at all when the mouse cursor is over certain areas of the page - in the example page, it's the background.
On this page, the background is created as <IMG>, with low "z-index" and a "position:fixed", which may be relevant:

#background-image {
    width:100%;
    z-index: 0;
    position:fixed;
    top:0;
    left:0;
}



Reproducible: Always

Steps to Reproduce:
1. visit the site
2. move mouse to lower left corner (NOT over menu box)
3. try to scroll with the mouse wheel

Actual Results:  
as described

Expected Results:  
as described
Same problem with Firefox2.0. Works fine on Trunk (Camino and Minefield).
This was possibly fixed on trunk by bug 317375, which also solved a number of z-index issues.
Firefox 2.0 Windows fails like Fx 2.0 Mac

This was fixed on trunk by the checkin for bug 258006.
Dupe ? not sure which flag to use...
Yeah, if the cause is a Core bug that was fixed on the trunk, dupe this to the fixed Core bug.

*** This bug has been marked as a duplicate of 258006 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.