Ability to load Error console in sidebar (with keyboard shortcut)

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
12 years ago
6 years ago

People

(Reporter: nick, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

This would be a great tool for web developers debugging various issues. The keyboard shortcut would allow switching from development back to bookmarks and vise-versa.

Reproducible: Always

Steps to Reproduce:
N/A
Confirming as a valid RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

12 years ago
Implementors: You'd also have to make sure that the individual messages are wrapped or cropped more aggressively. Console² ( https://addons.mozilla.org/firefox/1815 ) which has been optimized for the sidebar could be used as a starting point - despite some effort it's not optimal, either, though.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
WONTFIXING this since:

1. This was originally a Firefox bug, and it never should have changed to Toolkit, since it's ultimately up to the host app to enable this.  Toolkit has no notion of sidebars.
2. Neither Firefox UX nor devtools are going to give this a "go", since the Web Console exists now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: Error Console → General
Product: Toolkit → Firefox
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.