using customize menu results in everything being grayed out after close.

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Harold J Drabkin, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2009-09-08])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I right click on a toolbar, and select customize. A pallet of icons drops down.
After clicking on "DONE", the "drawer" closes, but
1. area where is was is now solid gray
2. All menu items in File, edit, view, history, bookmarks, tools, windows, and help are grayed out.
3.  nothing responds; no icons work.
4. Need to go to Firefox:quit to close program and then manually restart

Reproducible: Always

Steps to Reproduce:
1.right click or ctrl-click to pull down menu
2.select customize
3.select "done"

Actual Results:  
area where customize pallete was is now gray
all menus grayed out; all buttons not responsize; scroll bar does nothing
force quite, or firefox:quit

Expected Results:  
same thing.

Area where drop down 'was" should return to what it was before.
All menus and buttons should function.
Have tried with two different themes.

Comment 1

12 years ago
WFM.  Can you try with a clean profile.

Comment 2

12 years ago
I was going to file this bug myself, but I found this report.
It is platform-independent (I'm using Windows XP).

It is likely an extension conflict, so here's My Config generated by Local Install.
http://www.madhatt.com/~bahamut/My%20Config/Firefox120106.html

Windows XP Home SP2 | Firefox (Portable) 2.0
(Reporter)

Comment 3

12 years ago
On my Mac (Tiger 10.4), it appears that this bug goes away if I disable an extension called "All In One Toolbar". 

However, if I open a new window (not tab) that one is not effected, and I can then close the grayed out window. However, the attempt at customization (adding an icon) does not happen. 
This effects ALL toolbars, not jus the All in One Toolbar.
This was not an issue prior to FF 2

(Reporter)

Comment 4

12 years ago
My error: the extension is called All in one Sidebar (AiOS), and the author's website acknowledges that it appears to prevent toolbar customization to function. Hopefully, he will fix this quickly.

Comment 5

11 years ago
Also, since I have the Stop-or-Reload extension, I normally see one button or the other. After this, I see both.

I have never used AiOS, nor do I have any other toolbars enabled.

Comment 6

11 years ago
I forgot to add that although the menubar options and the "Customize..." option are disabled, the scrollbar and buttons are not affected.
This isn't a bug, it's a symptom: anything that causes a fatal JavaScript error as the customization window closes will prevent the callback that re-enables the menus. You can find out what actual bug you are seeing by using about:config to toggle the pref javascript.options.showInConsole to true, then opening the Error Console (first, since you aren't going to have menus afterward), opening and closing the customization window, and seeing what error pops up in the console. Chances are very very good that the reported error will be in a file like chrome://foopy/... where foopy is something that sounds like the name of one of your extensions, and then you'll know what extension author to contact to get the problem fixed.

Comment 8

11 years ago
Fatal JavaScript errors (some were there before using Customize...):

abctajpu's error is "laert is not defined" (I copied the following after disabling abctajpu).

Error: missing catch or finally after try
Source File: chrome://longtitles/content/longtitles.xul
Line: 86, Column: 2
Source Code:
		}
Long Titles.

Error: searchcontainer has no properties
Source File: chrome://wellrounded/content/wellrounded.js
Line: 88
WellRounded.

Error: Components.classes['@wkwkrl.jp/humor/tab_effect;1'] has no properties
Source File: chrome://tab_effect/content/javascript.js
Line: 6
Tab Effect.

Error: gBrowser is not defined
Source File: chrome://reporter/content/reporterOverlay.js
Line: 74
I do not know which, if any, extension are responsible for this.

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/search/search.xml ::  :: line 109"  data: no]
Looks like an error from the browser itself.

Error: BrowserToolboxCustomizeDone_ is not defined
Source File: chrome://tabmixplus/content/minit/tablib.js
Line: 371
Tab Mix Plus.

Error: searchcontainer has no properties
Source File: chrome://wellrounded/content/wellrounded.js
Line: 88
WellRounded again.

Error: stopIsValid is not defined
Source File: chrome://fasterfox/content/listener-fasterfox.js
Line: 60
FasterFox.

Error: Components.classes['@wkwkrl.jp/humor/tab_effect;1'] has no properties
Source File: chrome://tab_effect/content/javascript.js
Line: 6
Tab Effect again.

I will notify the authors.

Comment 9

11 years ago
(In reply to comment #8)
> Fatal JavaScript errors (some were there before using Customize...):
> 
> abctajpu's error is "laert is not defined" (I copied the following after
> disabling abctajpu).
> 
> Error: missing catch or finally after try
> Source File: chrome://longtitles/content/longtitles.xul
> Line: 86, Column: 2
> Source Code:
>                 }
> Long Titles.

This is a known bug of my extension.
I fixed it once but then the tooltips didn't reappear without having to reload the page, so I left it there. It happens once at each start of Firefox. I never heard it caused more trouble than this error in javascript console, but it may have missed some things.

Anyway, I can't reproduce your bug myself. Could you please : 

- Clear your error console before triggering the bug, in order to find out which extension(s) really causes the fatal Javascript Error?

- Find the minimal set of extensions to reproduce this? I.e. the set of extensions with which, when you disable any of them, the bug stops? As you have loads of extensions, you can do that a little bit "more easily" than disabling them one by one in the extensions manager : stop Firefox, open the "extensions" folder in your profile, and move half of your extensions elsewhere. Start Firefox and see if the bug still appears. If it does, you have decreased the number of extensions to investigate by two (it may be slightly more complicated than that as several extensions may be involved).

Then you might want to try on a new profile if the bug is still here (sometimes it can happen that a specific configuration triggers some strange behaviour).

This is a lot of work for you to do, but it is probably essential to have it fixed.

Comment 10

11 years ago
After clearing the console and opening the customize window:
Error: gBrowser is not defined
Source File: chrome://reporter/content/reporterOverlay.js
Line: 74
This is part of the inspector component, which is included with the standard distribution.

After closing it:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/search/search.xml ::  :: line 109"  data: no]

Error: BrowserToolboxCustomizeDone_ is not defined
Source File: chrome://tabmixplus/content/minit/tablib.js
Line: 371
The first is part of the browser, and the second is part of Tab Mix Plus. I will ask on the TMP forums if anyone else gets this error after using Customize....
Does someone experience this problem with Firefox 3.5.x?
Whiteboard: [closeme 2009-09-09]
Version: unspecified → 2.0 Branch
WFM with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a2pre) Gecko/20090901 Namoroka/3.6a2pre ID:20090901173911

Feel free to reopen if it is still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2009-09-09] → [closeme 2009-09-08]
You need to log in before you can comment on or make changes to this bug.